[Usaco2015 Feb]Censoring

Posted cutemush

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[Usaco2015 Feb]Censoring相关的知识,希望对你有一定的参考价值。

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn‘t exist before.

Please help FJ determine the final contents of S after censoring is complete

有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。

Input
The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).
Output
The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.
Sample Input
whatthemomooofun

moo
Sample Output
whatthefun
每次s中字母压入栈中,处理出t的next数组,从头进行匹配,记录匹配到的位置,如果匹配的长度为t,就暴力把整个字符串出栈,接着j应该变为栈顶元素所匹配的位置。

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1000050;
int nxt[maxn],n,m,ans,st1[maxn];
char s1[maxn],s2[maxn],st[maxn];
void getnxt()
{
for(int i=2,j=0;i<=m;i++)
{
while(j&&s2[j+1]!=s2[i])j=nxt[j];
if(s2[j+1]==s2[i])j++;
nxt[i]=j;
}
}
int main()
{
ans=0;
scanf("%s%s",s2+1,s1+1);
m=strlen(s2+1);
n=strlen(s1+1);
getnxt();
int top=0,i=1,j=0,ans=0;
while(i<=n)
{
st[++top]=s1[i];//第一个字符的第i个进栈
while(j&&s2[j+1]!=s1[i])
//j代表栈顶字符,可与s2的前J个字符相匹配
j=nxt[j];
if(s2[j+1]==st[top])//如果匹配成功
++j;
st1[top]=j;
if(j==m) //如果完全与s2匹配
top-=m,j=st1[top],ans++;
++i;
}
printf("%d",ans);
return 0;
}

  

 

以上是关于[Usaco2015 Feb]Censoring的主要内容,如果未能解决你的问题,请参考以下文章

[Usaco2015 Feb]Censoring

USACO 2015 Feb Censoring

bzoj 3940: [Usaco2015 Feb]Censoring -- AC自动机

bzoj3940 [Usaco2015 Feb]Censoring

bzoj3940[Usaco2015 Feb]Censoring*

bzoj3942[Usaco2015 Feb]Censoring*