1054 The Dominant Color (20)(20 分)

Posted wanghao-boke

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1054 The Dominant Color (20)(20 分)相关的知识,希望对你有一定的参考价值。

Behind the scenes in the computer‘s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 2^24^). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24
#include<cstdio>
int main(){
    int m,n,col,ans= -1,count = 0;
    scanf("%d%d",&m,&n);
    for(int i = 0; i < m; i++){
        for(int i = 0; i < n; i++){
            scanf("%d",&col);
            if(count == 0){
                ans = col;
                count = 1;
            }
            else{
                if(ans  == col) count++;
                else count--;
            }
        }
    }
    printf("%d",ans);
    return 0;
}

 

#include<cstdio>
#include<map>
using namespace std;
int main(){
    int n,m,col;
    map<int,int> count;
    scanf("%d%d",&m,&n);
    for(int i = 0; i < m; i++){
        for(int j= 0; j < n; j++){
            scanf("%d",&col);
            if(count.find(col)!=count.end()) count[col]++;
            else count[col] = 1;
        }
    }
    int k = 0, max = 0;
    for(map<int,int>::iterator it=count.begin(); it != count.end(); it++){
        if(it -> second  > max){
            k = it -> first;
            max = it -> second;
        }
    }
    printf("%d",k);
    return 0;
}

 

以上是关于1054 The Dominant Color (20)(20 分)的主要内容,如果未能解决你的问题,请参考以下文章

1054 The Dominant Color (20)(20 分)

PAT1054. The Dominant Color (20)

PAT 甲级 1054 The Dominant Color (20 分)(简单题)

PAT Advanced 1054 The Dominant Color (20分)

1054 The Dominant Color

1054 The Dominant Color