111

Posted wven

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了111相关的知识,希望对你有一定的参考价值。

练习3-8 查询水果价格 (15分)
 

给定四种水果,分别是苹果(apple)、梨(pear)、桔子(orange)、葡萄(grape),单价分别对应为3.00元/公斤、2.50元/公斤、4.10元/公斤、10.20元/公斤。

首先在屏幕上显示以下菜单:

[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
 

用户可以输入编号1~4查询对应水果的单价。当连续查询次数超过5次时,程序应自动退出查询;不到5次而用户输入0即退出;输入其他编号,显示价格为0。

输入格式:

输入在一行中给出用户连续输入的若干个编号。

输出格式:

首先在屏幕上显示菜单。然后对应用户的每个输入,在一行中按格式“price = 价格”输出查询结果,其中价格保留两位小数。当用户连续查询次数超过5次、或主动输入0时,程序结束。

输入样例1:

3 -1 0 2
 

输出样例1:

[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
price = 4.10
price = 0.00
 

输入样例2:

1 2 3 3 4 4 5 6 7 8
 

输出样例2:

[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
price = 3.00
price = 2.50
price = 4.10
price = 4.10
price = 10.20



//有点尴尬的是,被中间一句话搞错了方向

#include<stdio.h>
int main()
{
int price,i;
printf("[1] apple ");
printf("[2] pear ");
printf("[3] orange ");
printf("[4] grape ");
printf("[0] exit ");
for(i=0;i<=4;i++)
{
scanf("%d",&price);
if(price==0) break;

switch(price)
{
case 1:printf("price = 3.00 ");break;
case 2:printf("price = 2.50 ");break;
case 3:printf("price = 4.10 ");break;
case 4:printf("price = 10.20 ");break;
default:printf("price = 0.00 ");break;
}
}
return 0;
}

以上是关于111的主要内容,如果未能解决你的问题,请参考以下文章

算法手撕代码111~120

微信小程序代码片段

VSCode自定义代码片段——CSS选择器

谷歌浏览器调试jsp 引入代码片段,如何调试代码片段中的js

片段和活动之间的核心区别是啥?哪些代码可以写成片段?

编写高质量代码改善C#程序的157个建议——建议111:避免双向耦合