PAT-1010 Radix

Posted chengdalei

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT-1010 Radix相关的知识,希望对你有一定的参考价值。

1010 Radix (25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

#include <iostream>
#include <cstring>
using namespace std;
#define Max 3
// 转成十进制 
long long toDecimal(char *N,long long radix){
    long long decimal=0;
    for(int i=0;i<strlen(N);i++){
        if(N[i]<58)
            decimal=decimal*radix+(N[i]-48);  // 0-9 
        else
            decimal=decimal*radix+(N[i]-87); // a-z ,10-35 呵呵 
    }
    return decimal;
}
//找出串中最大值 
int maxValueStr(char *N){
    int max=0;
    for(int i=0;i<strlen(N);i++)
        if(N[i]<58&&N[i]-48>max)
            max=N[i]-48;
        else if(N[i]-87>max)
            max=N[i]-87; 
    if(max>1)
        return max;
    else
        return 1;
}
int compare(char *N,long long radix,long long target){
    long long decimal=0;
    for(int i=0;i<strlen(N);i++){
        if(N[i]<58)
            decimal=decimal*radix+(N[i]-48);
        else
            decimal=decimal*radix+(N[i]-87);
        if(decimal>target||decimal<0)
            return 1; 
    }
    if(decimal>target)
        return 1;
    else if(decimal<target)
        return -1;
    else
        return 0;
}
long long binarySearch(long long target,char *N,long long low,long long high){
    long long mid=low;
    
    while(low<=high){
        if(compare(N,mid,target)==1)
            high=mid-1;
        else if(compare(N,mid,target)==-1)
            low=mid+1;
        else
            return mid;
        mid=(low+high)/2;
    }
    return -1;
}   
int main(int argc, char* argv[])
{
    char *N[Max];
    
    long long radix,target;
    int tag;
    for(int i=0;i<Max;i++)
        N[i]=new char[10]();
    
    cin >> N[1] >> N[2] >> tag >> radix;
    
    target=toDecimal(N[tag],radix); //目标数转成十进制比较 
    tag=(tag==1)? 2:1;
    long long max=(long long)maxValueStr(N[tag])+1;
    
    if(target<=max){
        long long r=binarySearch(target,N[tag],max,36);
        if(r==-1)
            cout<<"Impossible";
        else
            cout<<r;
    }else{
        long long r=binarySearch(target,N[tag],max,target+1);
        if(r==-1)
            cout<<"Impossible";
        else
            cout<<r;
    }
    return 0;
}

以上是关于PAT-1010 Radix的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1010 Radix (二分)

pat 1010 Radix

PAT 1010 Radix (25分) radix取值无限制,二分法提高效率

PAT 1010 Radix 进制转换+二分法

PAT1010

PAT T1010 Lehmer Code