题解骨牌

Posted kcn999

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了题解骨牌相关的知识,希望对你有一定的参考价值。

题目描述

  有1×n的一个长方形,用一个1×1、1×2和1×3的骨牌铺满方格。

  例如当n=3时为1×3的方格。此时用1×1、1×2和1×3的骨牌铺满方格,共有四种铺法。

  那么有1×n的一个长方形,共有多少种铺法?

技术图片

 

输入输出格式

输入格式

  一行,一个整数n,n≤10。

 

输出格式

  一行,一个整数,表示有多少种不同的铺法。

 

输入输出样例

输入样例

3

 

输出样例

4

 

题解

  递推水题,如题描述做即可。

技术图片
#include <iostream>
#include <algorithm>

using namespace std;

int n;
int a[11] = {0,1,2,4};

int main()
{
    cin >> n;
    for(register int i = 4; i <= n; i++) a[i] = a[i - 3] + a[i - 2] + a[i - 1];
    cout << a[n];
    return 0;
}
参考程序

 

以上是关于题解骨牌的主要内容,如果未能解决你的问题,请参考以下文章

多米诺骨牌

Codeforces Round #742 (Div. 2) 题解

学长出题比赛题解17-09-29

uva 10529 Dumb Bones(概率与期望,期望dp)带公式推导的题解

Codeforces Round #742 div.2 A-F题解

Codeforces Round #742 div.2 A-F题解