POJ1932 HDU1317 ZOJ1935 UVA10557 XYZZYSPFA+Floyd
Posted tigerisland45
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ1932 HDU1317 ZOJ1935 UVA10557 XYZZYSPFA+Floyd相关的知识,希望对你有一定的参考价值。
XYZZY
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4217 Accepted: 1203
Description
The prototypical computer adventure game, first designed by Will Crowther on the PDP-10 in the mid-1970s as an attempt at computer-refereed fantasy gaming, and expanded into a puzzle-oriented game by Don Woods at Stanford in 1976. (Woods had been one of the authors of INTERCAL.) Now better known as Adventure or Colossal Cave Adventure, but the TOPS-10 operating system permitted only six-letter filenames in uppercase. See also vadding, Zork, and Infocom.
It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable.
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms.
The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player‘s energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time.
Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing:
the energy value for room i
the number of doorways leaving room i
a list of the rooms that are reachable by the doorways leaving room i
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.
Output
In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".
Sample Input
5
0 1 2
-60 1 3
-60 1 4
20 1 5
0 0
5
0 1 2
20 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
21 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
20 2 1 3
-60 1 4
-60 1 5
0 0
-1
Sample Output
hopeless
hopeless
winnable
winnable
Source
问题链接:POJ1932 HDU1317 ZOJ1935 UVA10557 XYZZY
问题简述:(略)
问题分析:
????给定一个单向图,每个结点有一个权值,每到一个点就要加上该点的权值,判断是否存在从结点1到结点n的路径。
????最短路的模板题,暂不解释。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C++语言程序如下:
/* POJ1932 HDU1317 ZOJ1935 UVA10557 XYZZY */
#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 100;
int g[N + 1][N + 1];
int w[N + 1];
int n;
int vis[N + 1];
int in[N + 1];
int dist[N + 1];
int spfa(int root)
{
memset(vis, 0, sizeof(vis));
memset(in, 0, sizeof(in));
memset(dist, 0, sizeof(dist));
queue <int> q;
dist[root] = 100;
vis[root] = 1;
in[root]++;
q.push(root);
while(!q.empty()) { //spfa
int u = q.front();
q.pop();
vis[u] = 0;
if(in[u] > n)
break;
for(int i = 1; i <= n; i++) {
if(g[u][i] && dist[i] < dist[u] + w[i]) {
dist[i] = dist[u] + w[i];
if(vis[i] == 0) {
vis[i] = 1;
q.push(i);
in[i]++;
}
}
}
}
if(dist[n] > 0) return 1; //存在最短路
else{
for(int k=1;k<=n;k++) //floyd
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
if(g[i][k] && g[k][j])
g[i][j]=1;
for(int i=1;i<=n;i++)
if(in[i]>n && g[1][i] && g[i][n]) //存在正环和连通
return 1;
}
return 0;
}
int main()
{
while(scanf("%d", &n) && n != -1) {
memset(g, 0, sizeof(g));
for(int u = 1; u <= n; u++) {
int m, v;
scanf("%d%d", &w[u], &m);
while(m--) {
scanf("%d", &v);
g[u][v] = 1;
}
}
printf(spfa(1) ? "winnable
" : "hopeless
");
}
return 0;
}
以上是关于POJ1932 HDU1317 ZOJ1935 UVA10557 XYZZYSPFA+Floyd的主要内容,如果未能解决你的问题,请参考以下文章
POJ2033 LA3078 HDU1508 ZOJ2202 AlphacodeDFS+DP
POJ1323 LA2521 HDU1338 ZOJ1362 Game Prediction贪心
POJ2092 LA3157 HDU1347 ZOJ2250 Grandpa is Famous排序
POJ1598 ZOJ1315 HDU1606 UVA409 UVALive5493 Excuses, Excuses!文本
POJ1573 ZOJ1708 UVA10116 UVALive5334 HDU1035 Robot MotionDFS+BFS