求最大值及其下标

Posted lwl123456789

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了求最大值及其下标相关的知识,希望对你有一定的参考价值。

7-2 求最大值及其下标 (20 分)

本题要求编写程序,找出给定的n个数中的最大值及其对应的最小下标(下标从0开始)。

 

输入格式:

 

输入在第一行中给出一个正整数n(1<n≤10)。第二行输入n个整数,用空格分开。

 

输出格式:

 

在一行中输出最大值及最大值的最小下标,中间用一个空格分开。

 

输入样例:

 

6

2 8 10 1 9 10

输出样例:

 

10 2

 

 

实验代码:

#include<stdio.h>
main()
{
 int n;
 scanf("%d",&n);
 int a[11];
 for(int i=0;i<n;i++)
 {
  scanf("%d",&a[i]);
 }
 int m=a[0];
 for(int i=0;i<n;i++)
 {
  if(a[i]>=m)
  {
   m=a[i];
  }
 }
  for(int i=0;i<n;i++)
 {
  if(m==a[i])
  {
   printf("%d %d",a[i],i);
   break;
  }
 }
}

 

运行截图:

技术图片

以上是关于求最大值及其下标的主要内容,如果未能解决你的问题,请参考以下文章

编程总结二 求最大值及其下标

7-2 求最大值及其下标 (20 分)

求最大值及其下标

7-2 求最大值及其下标

求最大值及其下标

求最大值及其下标