SDNU 1410.FJ的字符串

Posted rootvount

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了SDNU 1410.FJ的字符串相关的知识,希望对你有一定的参考价值。

Description

由样例可知,每个字符串长度是前一个字符串长度的2倍+1;
字符串顺序为 :An 某个字母 An
FJ在沙盘上写了这样一些字符串:
A1  =  “A”
A2  =  “ABA”
A3  =  “ABACABA”
A4  =  “ABACABADABACABA”
…  …
你能找出其中的规律并写所有的数列AN吗? 

Input

仅有一个数:N  ≤  26。 

Output

请输出相应的字符串AN,以一个换行符结束。输出中不得含有多余的空格或换行、回车符。

Sample Input

3

Sample Output

ABACABA 
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <string>

using namespace std;

string miao[30];
string n[30] = {"A", "B", "C", "D", "E", "F", "G", "H", "I", "J", "K", "L", "M", "N" ,"O", "P", "Q", "R", "S", "T", "U", "V", "W", "X", "Y", "Z"};

int main()
{
    int m;
    miao[1] = "A";
    for(int i = 2; i <= 27; i++)
    {
        miao[i] = miao[i-1]+n[i-1]+miao[i-1];
    }
    while(~scanf("%d", &m))
    {
        cout<<miao[m]<<endl;
    }
    return 0;
}

 

以上是关于SDNU 1410.FJ的字符串的主要内容,如果未能解决你的问题,请参考以下文章

SDNU 1093.DNA排序(水题)

SDNU 1440.字母图形

SDNU 1206.蚂蚁感冒 代码如此简单,思维练习7月29

SDNU 1303.A+B(高精度)

SDNU 1279.※N

SDNU 1274.Identity Card