SPOJ-BEADS UVA719 UVALive5545 POJ1509 ZOJ2006 Glass Beads字符串环的最小
Posted tigerisland45
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了SPOJ-BEADS UVA719 UVALive5545 POJ1509 ZOJ2006 Glass Beads字符串环的最小相关的知识,希望对你有一定的参考价值。
Glass Beads
Time Limit: 3000MS Memory Limit: 10000K
Total Submissions: 5254 Accepted: 2943
Description
Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace.
The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads.
The description of the necklace is a string A = a1a2 ... am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion.
The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 ... ana1 ... ai-1 is lexicografically smaller than the string ajaj+1 ... ana1 ... aj-1. String a1a2 ... an is lexicografically smaller than the string b1b2 ... bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a--z), where a < b ... z.
Output
For each case, print exactly one line containing only one integer -- number of the bead which is the first at the worst possible disjoining, i.e.?such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.
Sample Input
4
helloworld
amandamanda
dontcallmebfu
aaabaaa
Sample Output
10
11
6
5
Source
Regionals 1998 >> Europe - Central
问题链接:SPOJ-BEADS UVA719 UVALive5545 POJ1509 ZOJ2006 Glass Beads
问题简述:(略)
问题分析:
????给定一个字符串构成一个环,问从什么位置开始的字符串其字典顺序最小?
????这个问题的解法有两种,一是用2个同样的字符串连接起来,然后从中取出同长度的子串进行比较找出字典顺序最小的(起始位置);二是直接按环进行比较,找出字典顺序最小的(起始位置)。后一种解法似乎值得推荐,模除即可实现环。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C++语言程序如下:
/* SPOJ-BEADS UVA719 UVALive5545 POJ1509 ZOJ2006 Glass Beads */
#include <iostream>
using namespace std;
int sr(string& s)
{
int i, j, k, len = s.length();
for(i = 0, j = 1; j < len;) {
for(k = 0; k < len && s[(i + k) % len] == s[(j + k) % len]; k++);
if(k >= len)
break;
if(s[(i + k) % len] < s[(j + k) % len])
j += k + 1;
else {
int l = i + k;
i = j;
j = max(l, j) + 1;
}
}
return i + 1;
}
int main()
{
ios::sync_with_stdio(false);
int n;
cin >> n;
while(n--) {
string s;
cin >> s;
cout << sr(s) << endl;
}
return 0;
}
AC的C++语言程序如下:
/* SPOJ-BEADS UVA719 UVALive5545 POJ1509 ZOJ2006 Glass Beads */
#include <iostream>
using namespace std;
int sr(string& s)
{
int i, j, k, len = s.length();
s += s;
for(i = 0, j = 1; j < len;) {
for(k = 0; k < len && s[i + k] == s[j + k]; k++);
if(k >= len)
break;
if(s[i + k] < s[j + k])
j += k + 1;
else {
int l = i + k;
i = j;
j = max(l, j) + 1;
}
}
return i + 1;
}
int main()
{
ios::sync_with_stdio(false);
int n;
cin >> n;
while(n--) {
string s;
cin >> s;
cout << sr(s) << endl;
}
return 0;
}
以上是关于SPOJ-BEADS UVA719 UVALive5545 POJ1509 ZOJ2006 Glass Beads字符串环的最小的主要内容,如果未能解决你的问题,请参考以下文章
UVA216 UVALive5155 Getting in Line置换+暴力
UVA699 UVALive5471 The Falling Leaves树权和