ansible 批量配置cisco 交换机---接口篇

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了ansible 批量配置cisco 交换机---接口篇相关的知识,希望对你有一定的参考价值。

关于ansible不做介绍。
本例主要通过实例介绍ansible配置ios接口的几种方法,或者说可利用哪些模块配置接口。

1 .主机列表,本次测试以1台主机为例

[[email protected] ansible]# cat hosts
[cisco]
172.16.254.130 ansible_connection=local 

2.playbooks内容

[[email protected] interface]# cat interface-phy.yml 
---
- name: interface config 
  hosts: cisco
 # vars: 
 #    creds:
 #         username: "{{ username }}"
 #         password: "{{ password }}"
  gather_facts: no

  tasks:
  - name: action interface G1-2 configure
    ios_config:
       lines:
          - no shutdown
          - switch mode trunk
          - switch trunk allow vlan all
          - do wr
       parents: interface range gigabitEthernet 1/0/1 - 2

  - name: action interface G3 configuration
    ios_l2_interface:
        name: GigabitEthernet1/0/3
        mode: access
        access_vlan: 100 

  - name: action interface G3 configuration
    ios_l2_interface: 
        name: GigabitEthernet1/0/4
        mode: trunk
        native_vlan: 100
        trunk_allowed_vlans: 10-255

  - name: save configuration
    ios_command:
         commands:
             -  wr

3.执行playbooks

[[email protected] interface]# ansible-playbook interface-phy.yml -u admin  -k 
SSH password: 

PLAY [interface config] **************************************************************************************************************

TASK [action interface G1-2 configure] ***********************************************************************************************
changed: [172.16.254.130]

TASK [action interface G3 configuration] *********************************************************************************************
changed: [172.16.254.130]

TASK [action interface G3 configuration] *********************************************************************************************
changed: [172.16.254.130]

TASK [save configuration] ************************************************************************************************************
ok: [172.16.254.130]

PLAY RECAP ***************************************************************************************************************************
172.16.254.130             : ok=4    changed=3    unreachable=0    failed=0   

4.查看执行效果

interface GigabitEthernet1/0/1
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 switchport access vlan 100
 switchport mode access
!
interface GigabitEthernet1/0/4
 switchport trunk native vlan 100
 switchport trunk allowed vlan 10-255
 switchport mode trunk
!
  1. 可见 ios_config和 ios_l2_interface 两个模块都可以操作,只有三层接口则可以使用ios_comfig或者ios_l3_interface模块。

以上是关于ansible 批量配置cisco 交换机---接口篇的主要内容,如果未能解决你的问题,请参考以下文章

cisco 路由器接防火墙再到核心交换机的网络映射问题

Cisco 路由器、交换机中各密码的作用

zabix 监控cisco SG200交换机 snmp

Cisco 三层交换机实验的结果

通过思科模拟器CISCO PACKET TRACER学习网络9——OSPF

通过linux的shell脚本批量处理交换机配置变更