P2759 奇怪的函数

Posted jcrl

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了P2759 奇怪的函数相关的知识,希望对你有一定的参考价值。

传送门

题目描述

使得 xxx^x xx达到或超过 n 位数字的最小正整数 x 是多少?

输入输出格式

输入格式:

一个正整数 n

输出格式:

使得 xxx^xxx 达到 n 位数字的最小正整数 x

输入输出样例

输入样例#1: 复制
11
输出样例#1: 复制
10

说明

n<=2000000000

#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstdio>
using namespace std;
long long n;
int main()
{
    cin>>n;
    long long l=1,r=2e9;
    while(l<r)
    {
        long long mid=(l+r)>>1;
        
        if((long long)(mid*log10(mid))+1<n)
        {
            l=mid+1;
        }
        else
        r=mid;
    }
    cout<<l;
}

 

以上是关于P2759 奇怪的函数的主要内容,如果未能解决你的问题,请参考以下文章

P2759 奇怪的函数

洛谷P2759奇怪的函数

P2759 奇怪的函数

luogu P2759 奇怪的函数 |二分答案

luogu P2759 奇怪的函数 二分答案+数论

好题收集 奇怪的函数(数学)