发现每年基本上都会有日期处理类的问题, 或者模拟,或者其他,所以就把历年所有日期问题都整理一下吧
输入 1998 输出 1998-2-13 1998-3-13 1998-11-13
题解:
-
首先是闰年判断
bool isLeap(int year) { return (year % 4 == 0 && year % 100 != 0) || (year % 400 == 0); }
-
其次是求指定日期是星期几 (当前日期到公元1年1月1日的天数 % 7 )
闰年时:((year-1)*365 + (year-1)/4 - year/100 + year/400 + b[i] + 1) % 7
平年时:((year-1)*365 + year / 4 -year/100 + year/400 + a[i] + 1) % 7
0:星期日 ,1:星期一,2:星期二,3:星期三,4:星期四,5:星期五,6:星期六
其中 a[i] 和 b[i] 指的是 该年1号 到 现在 的天数。这是因为我们知道公元1年1月1日是星期一
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
using namespace std;
?
//闰年29天
bool isLeap(int year)
{
return (year % 4 == 0 && year % 100 != 0) || (year % 400 == 0);
}
?
int main()
{
int year, ans = 0;
//闰年的:每年一日到该月13日的天数
int Leap[] = {12, 31+12, 31+29+12, 31+29+31+12, 31+29+31+30+12, 31+29+31+30+31+12,
31+29+31+30+31+30+12, 31+29+31+30+31+30+31+12, 31+29+31+30+31+30+31+31+12,
31+29+31+30+31+30+31+31+30+12, 31+29+31+30+31+30+31+31+30+31+12, 31+29+31+30+31+30+31+31+30+31+30+12 };
//平年的:每年一日到该月13日的天数
int not_Leap[] = {12, 31+12, 31+28+12, 31+28+31+12, 31+28+31+30+12, 31+28+31+30+31+12,
31+28+31+30+31+30+12, 31+28+31+30+31+30+31+12, 31+28+31+30+31+30+31+31+12,
31+28+31+30+31+30+31+31+30+12, 31+28+31+30+31+30+31+31+30+31+12, 31+28+31+30+31+30+31+31+30+31+30+12};
cin >> year;
if (isLeap(year))
{
for (int i = 0; i < 12; i++)
{
if (((year-1)*365 + (year-1)/4 - year/100 + year/400 + Leap[i] + 1) % 7 == 5) {
printf("%d-%d-13\n", year, i + 1);
ans++;
}
}
}
else
{
for (int i = 0; i < 12; i++)
{
if (((year-1)*365 + (year)/4 - year/100 + year/400 + not_Leap[i] + 1) % 7 == 5) {
printf("%d-%d-13\n", year, i + 1);
ans++;
}
}
}
printf("%d\n", ans);
return 0;
}
-
可以在 蓝桥杯官网 算法提高 黑色星期五 提交这题,只要把 printf() 注释掉就好
例题2 (2013年第四届蓝桥杯B组(C/C++)预赛 第一题)
题目标题: 高斯日记
?
大数学家高斯有个好习惯:无论如何都要记日记。
?
他的日记有个与众不同的地方,他从不注明年月日,而是用一个整数代替,比如:4210
?
后来人们知道,那个整数就是日期,它表示那一天是高斯出生后的第几天。这或许也是个好习惯,它时时刻刻提醒着主人:日子又过去一天,还有多少时光可以用于浪费呢?
?
高斯出生于:1777年4月30日。
在高斯发现的一个重要定理的日记上标注着:5343,因此可算出那天是:1791年12月15日。
?
高斯获得博士学位的那天日记上标着:8113
?
请你算出高斯获得博士学位的年月日。
?
提交答案的格式是:yyyy-mm-dd, 例如:1980-03-21
?
请严格按照格式,通过浏览器提交答案。
注意:只提交这个日期,不要写其它附加内容,比如:说明性的文字。
题解:
两种解法:
利用Excel,打开Excel,比赛时候可以用!!!
代码计算
#include <iostream> using namespace std; ? int year = 1777, month = 4, day = 30; ? bool IsEndofMonth(); void AddDay(int days); void IncDay(); bool IsLeapYear(); ? bool IsLeapYear() { return (year % 4 == 0 && year % 100 != 0) || (year % 400 == 0); } ? bool IsEndofMonth() { switch(month) { case 4: case 6: case 9: case 11: return day == 30; case 2: if (IsLeapYear()) return day == 29; else return day == 28; default: return day == 31; } } ? void IncDay() //增加一天 { if(IsEndofMonth()) //增加天数,记得要判断是否是年末,月末 { if(month == 12) { day = 1; month = 1; year++; } else { //已经是IsEndMonth day = 1; month++; } } else { day++; } } ? void AddDay(int days) { for (int i = 1; i < days; i++) //增加多少天 days - 1 { IncDay(); } } ? int main() { // AddDay(5343); AddDay(8113); cout << year << "-" << month << "-" << day << endl; return 0; } ?
例3、星系炸弹(2015年第六届蓝桥杯B组(C/C++)预赛 第二题)
在X星系的广袤空间中漂浮着许多X星人造“炸弹”,用来作为宇宙中的路标。
每个炸弹都可以设定多少天之后爆炸。
比如:阿尔法炸弹2015年1月1日放置,定时为15天,则它在2015年1月16日爆炸。
有一个贝塔炸弹,2014年11月9日放置,定时为1000天,请你计算它爆炸的准确日期。
请填写该日期,格式为 yyyy-mm-dd 即4位年份2位月份2位日期。比如:2015-02-19
请严格按照格式书写。不能出现其它文字或符号。
解:和上一题一样啊(就是上一题几天后是算几天,这题的几天后是不算几天)
#include <iostream> using namespace std; ? int year = 1777, month = 4, day = 30; ? bool IsEndofMonth(); void AddDay(int days); void IncDay(); bool IsLeapYear(); ? bool IsLeapYear() { return (year % 4 == 0 && year % 100 != 0) || (year % 400 == 0); } ? bool IsEndofMonth() { switch(month) { case 4: case 6: case 9: case 11: return day == 30; case 2: if (IsLeapYear()) return day == 29; else return day == 28; default: return day == 31; } } ? void IncDay() //增加一天 { if(IsEndofMonth()) //增加天数,记得要判断是否是年末,月末 { if(month == 12) { day = 1; month = 1; year++; } else { //已经是IsEndMonth day = 1; month++; } } else { day++; } } ? void AddDay(int days) { for (int i = 1; i <= days; i++) //增加多少天 days - 1 { IncDay(); } } ? int main() { // AddDay(5343); cin >> year >> month >> day; AddDay(1000); cout << year << "-" << month << "-" << day << endl; return 0; } ?
例4 (2017第八届蓝桥杯C/C++ B组省赛 第7题)
标题:日期问题
?
小明正在整理一批历史文献。这些历史文献中出现了很多日期。小明知道这些日期都在1960年1月1日至2059年12月31日。令小明头疼的是,这些日期采用的格式非常不统一,有采用年/月/日的,有采用月/日/年的,还有采用日/月/年的。更加麻烦的是,年份也都省略了前两位,使得文献上的一个日期,存在很多可能的日期与其对应。
?
比如02/03/04,可能是2002年03月04日、2004年02月03日或2004年03月02日。
?
给出一个文献上的日期,你能帮助小明判断有哪些可能的日期对其对应吗?
?
输入
----
一个日期,格式是"AA/BB/CC"。 (0 <= A, B, C <= 9)
?
输出
----
输出若干个不相同的日期,每个日期一行,格式是"yyyy-MM-dd"。多个日期按从早到晚排列。
?
样例输入
----
02/03/04
?
样例输出
----
2002-03-04
2004-02-03
2004-03-02
?
资源约定:
峰值内存消耗(含虚拟机) < 256M
CPU消耗 < 1000ms
题解:把三种日期格式对应日期都枚举出来,然后排除非法日期和不在题目所述范围的日期。最后去重排序
#include <algorithm>
#include <cstring>
#include <iostream>
#include <cstdio>
#include <string>
#include <queue>
#include <map>
#include <set>
using namespace std;
int md[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
struct date
{
int year;
int month;
int day;
date(int y,int m,int d)
{
year = y;
month = m;
day = d;
}
bool operator < (date other)const{
if(year == other.year)
{
if(month == other.month)
return day<other.day;
return month<other.month;
}
return year<other.year;
}
bool vial(){ //判断日期是否非法
if(year < 1960 || year > 2059) return false;
if(month <= 0 || month > 12) return false;
if(year % 400 == 0 || (year % 100 != 0 && year % 4 == 0))
{
//闰年
if(month == 2)
{
return day >= 1 && day <= 29;
}
return day >= 1 && day <= md[month];
}
else {
return day >= 1 && day <= md[month];
}
}
void print() const{
printf("%d-%02d-%02d\n",year,month,day);
}
};
set<date> ss; //利用set容器来去重排序
void insert(int a,int b,int c)
{
date obj(a,b,c);
if(obj.vial()) ss.insert(obj);
}
int main()
{
int a,b,c;
scanf("%d/%d/%d", &a, &b, &c);
//年月日
insert(1900+a,b,c);
insert(2000+a,b,c);
//月日年
insert(1900+c,a,b);
insert(2000+c,a,b);
//日月年
insert(1900+c,b,a);
insert(2000+c,b,a);
set<date>::iterator it = ss.begin();
for(; it != ss.end() ; it ++)
{
it->print();
}
return 0;
}
参考了这篇:http://blog.csdn.net/y1196645376/article/details/69718192/