51nod 1012 最小公倍数LCM

Posted 8023spz

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了51nod 1012 最小公倍数LCM相关的知识,希望对你有一定的参考价值。

输入2个正整数A,B,求A与B的最小公倍数。
 

输入

2个数A,B,中间用空格隔开。(1<= A,B <= 10^9)

输出

输出A与B的最小公倍数。

输入样例

30 105

输出样例

210

代码:
#include <iostream>
#include <cstdio>
#include <cmath>
#define MAX 50000

using namespace std;
typedef long long ll;
int gcd(int a,int b) {
    while(b ^= a ^= b ^= a %= b);
    return a;
}
int main() {
    int a,b;
    scanf("%d%d",&a,&b);
    printf("%lld",(ll)a / gcd(a,b) * b);
}

 

以上是关于51nod 1012 最小公倍数LCM的主要内容,如果未能解决你的问题,请参考以下文章

51nod 1012最小公倍数LCM

51NOD-01012 最小公倍数LCM

51nod 1434 区间LCM 素数

51NOD 1434 区间LCM(素数筛)

51nod 1190 最小公倍数之和 V2

1012 最小公倍数LCM