Tju_Oj_3988Password

Posted jeasoniscoding

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Tju_Oj_3988Password相关的知识,希望对你有一定的参考价值。

这个题是给树的前序和中序,输出后序。

做法是根据前序找根,根据根在中序中找中序的左右子树,根据左右子树长度找前序的左右子树,依此递归。

做过之后感觉还是比较基础的,废话不多说,上题上代码。

 

Bob will get a bag as gift from Alice, but Alice don‘t wanna Bob get the bag without did anything, so she put the bag into a safe box... Alice will give two hints about password to Bob. One is the preorder traversal(root, left subtree, right subtree) of a binary tree, another is the inorder traversal(left subtree, root, right subtree) of the same tree. The password is the postorder traversal(left subtree, right subtree, root) of the tree.
For example:

技术分享图片

The tree only has three nodes A, B and C.
Its preorder traversal is ABC, inorder traversal is BAC, and postorder traversal is BCA.

 

Input

There are several test cases in the input file, Each test case contains two line. Preorder traversal and Inorder traversal.(Each line‘s length won‘t longer than 26, and only contain upper letter)

Output

For each test case, output the password Bob need.

Sample Input

ABC
BAC

Sample Output

BCA

 

 

 

/*
 * 3988_Password.cpp
 *    给出字母的前序和中序,求后序
 *  Created on: 2018年11月8日
 *      Author: Jeason
 */

#include <iostream>
#include <fstream>
#include <string>
#include <vector>
#define MAX 100
using namespace std;

void find(string tree_fro , string tree_mid)
{
    char root = tree_fro[0];

    int num_leftSubTree = tree_mid.find(root);
    int num_rightSubTree = tree_mid.length() - num_leftSubTree - 1;
    if ( tree_fro.length() == 1 ){
        cout << root ;
        return;
    }
    if(num_leftSubTree != 0) {
        string leftSubTree_mid = tree_mid.substr( 0, num_leftSubTree );
        string leftSubTree_fro = tree_fro.substr( 1,num_leftSubTree);
        find( leftSubTree_fro , leftSubTree_mid );
    }
    if(num_rightSubTree != 0) {
        string rightSubTree_mid = tree_mid.substr( num_leftSubTree + 1 ,num_rightSubTree );
        string rightSubTree_fro = tree_fro.substr(num_leftSubTree + 1 ,num_rightSubTree );
        find( rightSubTree_fro , rightSubTree_mid );
    }

    cout << root;
    return;
}

int main()
{
    string tree_fro;
    string tree_mid;
    while(cin >> tree_fro){
        cin >> tree_mid;
        find(tree_fro , tree_mid);
        cout << endl;
    }

    return 0;
}

/*
Sample Input

ABC
BAC
Sample Output

BCA

*/

 



以上是关于Tju_Oj_3988Password的主要内容,如果未能解决你的问题,请参考以下文章

Tju_Oj_3517The longest athletic track

P3988 [SHOI2013]发牌

连接MySQL出现错误:ERROR 1045 (28000): Access denied for user ‘root‘@‘localhost‘ (using password: YES)(代码片段

zoj3988 Prime Set

Harry Potter and the Hide Story(hdu3988)

修改MySQL密码报错“ERROR 1819 (HY000): Your password does not satisfy the current policy requirements“(代码片段