4401: 优美数
Posted mch5201314
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了4401: 优美数相关的知识,希望对你有一定的参考价值。
链接
[http://oj.acm.zstu.edu.cn/JudgeOnline/problem.php?id=4401]
题意
Description
如果一个数中只有少于三个数字是非零的,那么我们称这个数为优美数,我们定义这个优美数的优美程度为这个数所有数字相加的和。 例如优美数有4,200000,10203,其中4的优美度是4,200000的优美度是2,10203的优美度是6. 数字4231,102306,7277420000,就不是啰。
现在问在【L,R】中,有多少个优美度为x的优美数。
Input
T组数据,T<=5e4. 第一行为组数T。 接下来T行,每组输入L,R,x。1<=L <= R <= 3e18;
Output
每行输出一个对应的答案
Sample Input
4
1 1000 1
1024 1024 7
65536 65536 15
1 1000000000 20
Sample Output
4
1
0
3024
分析
数位DP
代码
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;
#define ll long long
using namespace std;
int a[30];
ll dp[20][30][4][30];
int k;
ll dfs(int pos,int now,int num,bool limit){//pos当前位数,now现在位数之和,num非零位的个数,limit判断是否到达上限
if(num > 3) return 0;
if(pos==-1) return now == k;
if(!limit && dp[pos][now][num][k]!=-1) return dp[pos][now][num][k];
int up=limit?a[pos]:9;
ll ans=0;
for(int i=0;i<=up&&now+i<=k;++i){
ans+=dfs(pos-1,now+i,num+(i!=0),limit&&i==a[pos]);
}
if(!limit) dp[pos][now][num][k]=ans;
return ans;
}
ll solve(ll x){
int pos=0;
if(x==0)return 0;
while(x){
a[pos++]=x%10;
x/=10;
}
return dfs(pos-1,0,0,1);
}
int main(){
int T;
//freopen("in.txt","r",stdin);
cin>>T;
memset(dp,-1,sizeof(dp));
while(T--){
ll l,r;
cin>>l>>r>>k;
if(k>27) cout<<0<<endl;
else
cout<<solve(r)-solve(l-1)<<endl;
}
return 0;
}
以上是关于4401: 优美数的主要内容,如果未能解决你的问题,请参考以下文章
追寻最优美的代码 leetcode 421. 数组中两个数的最大异或值