POJ 2387 Til the Cows Come Home
Posted cantredo
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2387 Til the Cows Come Home相关的知识,希望对你有一定的参考价值。
Til the Cows Come Home
| Time Limit: 1000MS | | Memory Limit: 65536K |
| Total Submissions: 76501 | | Accepted: 25456 |
Description
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.
Farmer John‘s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
Line 1: Two integers: T and N
Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
- Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
Hint
INPUT DETAILS:
There are five landmarks.
OUTPUT DETAILS:
Bessie can get home by following trails 4, 3, 2, and 1.
Source
题解
dijkstra寻找最短路模版题。代码如下:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std ;
const int INF = 0x3f3f3f3f ;
const int MAXN = 2005 ;
int dis[MAXN] ;
int map[MAXN][MAXN] ;
bool vis[MAXN] ;
int n , m ;
void dijkstra(){
int cur = 1 ;
dis[cur] = 0 ;
vis[cur] = true ;
for ( int i = 1 ; i <= n ; i ++ ){
for ( int j = 1 ; j <= n ; j ++ ){
if ( !vis[j] && map[cur][j] + dis[cur] < dis[j] ){
dis[j] = map[cur][j] + dis[cur] ;
}
}
int mini = INF ;
for ( int j = 1 ; j <= n ; j ++ ){
if ( !vis[j] && dis[j] < mini ){
mini = dis[cur=j] ;
}
}
vis[cur] = true ;
}
}
void init(){
memset(vis , false , sizeof(vis)) ;
for ( int i = 1 ; i <= n ; i ++ ){
dis[i] = INF ;
for ( int j = 1 ; j <= n ; j ++ ){
map[i][j] = INF ;
}
}
return ;
}
int main(){
while ( cin >> m >> n ){
init() ;
for ( int i = 0 ; i < m ; i ++ ){
int from , to , val ;
cin >> from >> to >> val ;
if ( map[from][to] > val ){
map[to][from] = map[from][to] = val ;
}
}
dijkstra() ;
cout << dis[n] << endl ;
}
return 0 ;
}
以上是关于POJ 2387 Til the Cows Come Home的主要内容,如果未能解决你的问题,请参考以下文章
POJ 2387 Til the Cows Come Home
POJ - 2387 Til the Cows Come Home
POJ-2387 Til the Cows Come Home ( 最短路 )
[POJ - 2387] L - Til the Cows Come Home(图论)