股票市场Stock Market(luogu 2938)

Posted qseer

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了股票市场Stock Market(luogu 2938)相关的知识,希望对你有一定的参考价值。

题目描述

Despite their innate prudence, the cows took a beating in the home mortgage market and now are trying their hand at stocks. Happily, Bessie is prescient and knows not only today‘s S (2 <= S <= 50) stock prices but also the future stock prices for a total of D days (2 <= D <= 10).

Given the matrix of current and future stock prices on various days (1 <= PR_sd <= 1,000) and an initial M (1 <= M <= 200,000) units of money, determine an optimal buying and selling strategy in order to maximize the gain realized by selling stock on the final day. Shares must be purchased in integer multiples, and you need not spend all the money (or any money). It is guaranteed that you will not be able to earn a profit of more than 500,000 units of money.

Consider the example below of a bull (i.e., improving) market, the kind Bessie likes most. In this case, S=2 stocks and D=3 days. The cows have 10 units of money to invest.

Today‘s price

| Tomorrow‘s price

| | Two days hence Stock | | | 1 10 15 15

2 13 11 20

If money is to be made, the cows must purchase stock 1 on day 1. Selling stock 1 on day 2 and quickly buying stock 2 yields 4 money in the bank and one share of 2. Selling stock 2 on the final day brings in 20 money for a total of 24 money when the 20 is added to the bank.

有S种股票,我们已经知道每一天每一种股票的价格。一共有d天,一开始拥有的钱为m,求最后总共能够拥有多少钱。

输入输出格式

输入格式:

 

* Line 1: Three space-separated integers: S, D, and M

* Lines 2..S+1: Line s+1 contains the D prices for stock s on days 1..D: PR_sd

 

输出格式:

 

* Line 1: The maximum amount of money possible to have after selling on day D.

 

输入输出样例

输入样例
2 3 10 
10 15 15 
13 11 20 
输出样例
24 

 

 

code(开 O(2) 才过)

#include<stdio.h>
#include<string.h>
#include<algorithm> 
using namespace std;
const int MX=510000;
int n,d,m,f[MX],pri[110][20];

int main() 
{
    scanf("%d%d%d",&n,&d,&m);
    for(int i=1;i<=n;++i) 
        for(int j=1;j<=d;++j) 
            scanf("%d",&pri[i][j]); 
    for(int k=2;k<=d;++k) { //前 k 天 
        int mx=0;
        memset(f,0,sizeof(f));
        for(int i=1;i<=n;++i) { //第 i 种股票 
            for(int j=pri[i][k-1];j<=m;++j) { //花 j 元 
                f[j]=max(f[j],f[j-pri[i][k-1]]+pri[i][k]-pri[i][k-1]); 
                mx=max(mx,f[j]);
            }
        }
        m+=mx; 
    }
    printf("%d",m);
    return 0;
}

 



以上是关于股票市场Stock Market(luogu 2938)的主要内容,如果未能解决你的问题,请参考以下文章

BZOJ1578: [Usaco2009 Feb]Stock Market 股票市场

[BZOJ1578] [Usaco2009 Feb]Stock Market 股票市场(DP)

Stock market clustering

word Stock Market Indices

The World's Top 15 Stock Exchanges by Domestic Market Capitalization

(zhuan) Using the latest advancements in AI to predict stock market movements