1041.simple sorting

Posted bernieloveslife

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1041.simple sorting相关的知识,希望对你有一定的参考价值。

题目描述:

You are given an unsorted array of integer numbers. Your task is to sort this array and kill possible duplicated elements occurring in it.
输入:

For each case, the first line of the input contains an integer number N representing the quantity of numbers in this array(1≤N≤1000). Next N lines contain N integer numbers(one number per each line) of the original array.
输出:

For each case ,outtput file should contain at most N numbers sorted in ascending order. Every number in the output file should occur only once.
样例输入:
6
8 8 7 3 7 7
样例输出:
3 7 8

 

#include<iostream>
#include<algorithm>
using namespace std;

int a[1001],b[1001];
int n;

int main(){
    int i;
    while(cin>>n){
        for(i=0;i<n;i++)
        {
            cin>>a[i];
        }
        sort(a,a+n);
        int num=0;
        b[0]=a[0];
        for(i=1;i<n;i++)
        {
            if(a[i]!=a[i-1]) b[++num]=a[i];
        }
        bool first=true;
        for(i=0;i<=num;i++){
            if(first) {
                first=false;
                cout<<b[i];
            }
            else cout<<" "<<b[i];
        }
        cout<<endl;
    }
    return 0;
}

 








以上是关于1041.simple sorting的主要内容,如果未能解决你的问题,请参考以下文章

题目1041:Simple Sorting-------注意最后一个数字的处理

python [代码片段]一些有趣的代码#sort

[原创]java WEB学习笔记61:Struts2学习之路--通用标签 property,uri,param,set,push,if-else,itertor,sort,date,a标签等(代码片段

代码片段 - Golang 实现集合操作

c ++ std :: sort intel编译器错误:访问冲突

java8 .stream().sorted().filter().map().collect()用法