1093.WERTYU

Posted bernieloveslife

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1093.WERTYU相关的知识,希望对你有一定的参考价值。

题目描述:

    A common typing error is to place the hands on the keyboard one row to the right of the correct position. So "Q" is typed as "W" and "J" is typed as "K" and so on. You are to decode a message typed in this manner.

输入:

    Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp, Control, etc.] are not represented in the input.

输出:

    You are to replace each letter or punctuation symbol by the one immediately to its left on the QWERTY keyboard shown above. Spaces in the input should be echoed in the output.

样例输入:
O S, GOMR YPFSU/
样例输出:
I AM FINE TODAY.

 

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;

char translate(char x){
    switch(x)
    {
        case W: x=Q;break;
        case E: x=W;break;
        case R: x=E;break;
        case T: x=R;break;
        case Y: x=T;break;
        case U: x=Y;break;
        case I: x=U;break;
        case O: x=I;break;
        case P: x=O;break;
        case [: x=P;break;
        case S: x=A;break;
        case D: x=S;break;
        case F: x=D;break;
        case G: x=F;break;
        case H: x=G;break;
        case J: x=H;break;
        case K: x=J;break;
        case L: x=K;break;
        case ;: x=L;break;
        case X: x=Z;break;
        case C: x=X;break;
        case V: x=C;break;
        case B: x=V;break;
        case N: x=B;break;
        case M: x=N;break;
        case ,: x=M;break;
        case .: x=,;break;
        case /: x=.;break; 
        case \: x=];break;         
    }
    return x;
}

int main(){
    char str[10000];
    char s[10000];
    while(gets(str)){
        int len=strlen(str);
        for(int i=0;i<len;i++)
        {
            if(str[i]== ) s[i]=str[i];
            else {
                s[i]=translate(str[i]);
            }
            cout<<s[i];
        }
        cout<<endl;
    }
    return 0;
}

 

以上是关于1093.WERTYU的主要内容,如果未能解决你的问题,请参考以下文章

VSCode自定义代码片段——CSS选择器

谷歌浏览器调试jsp 引入代码片段,如何调试代码片段中的js

片段和活动之间的核心区别是啥?哪些代码可以写成片段?

VSCode自定义代码片段——.vue文件的模板

VSCode自定义代码片段6——CSS选择器

VSCode自定义代码片段——声明函数