1001.A+B for Matrices

Posted bernieloveslife

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1001.A+B for Matrices相关的知识,希望对你有一定的参考价值。

题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5

 

#include<iostream>
using namespace std;

int main(){
    int a[15][15]={0},b[15][15]={0};
    int m,n,i,j;
    while(cin>>m){
        int num=0;
        int sum1,sum2;
        if(m==0) break;
        cin>>n;
        for(i=0;i<m;i++){
            for(j=0;j<n;j++){
                cin>>a[i][j];
            }
        }
        for(i=0;i<m;i++){
            for(j=0;j<n;j++){
                cin>>b[i][j];
            }
        }
        for(i=0;i<m;i++){
            sum1=0,sum2=0;
            for(j=0;j<n;j++){
                sum1+=a[i][j];
                sum2+=b[i][j];
            }
            if(sum1+sum2==0) num++;
        }
        for(j=0;j<n;j++){
            sum1=0,sum2=0;
            for(i=0;i<m;i++){
                sum1+=a[i][j];
                sum2+=b[i][j];
            }
            if(sum1+sum2==0) num++;
        }
    cout<<num<<endl;
    }
    return 0;
} 

 

以上是关于1001.A+B for Matrices的主要内容,如果未能解决你的问题,请参考以下文章

1001.A+B for Matrices

PAT-甲级-1001-A+B for Polynomials

Triplet Format for Sparse Matrices

论文笔记-Augmented Lagrange Multiplier Method for Recovery of Low-Rank Matrices

论文笔记-Augmented Lagrange Multiplier Method for Recovery of Low-Rank Matrices

论文笔记-Augmented Lagrange Multiplier Method for Recovery of Low-Rank Matrices