2018ICPC南京网络赛 AAn Olympian Math Problem(数论题)

Posted kannyi

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了2018ICPC南京网络赛 AAn Olympian Math Problem(数论题)相关的知识,希望对你有一定的参考价值。

Alice, a student of grade 6, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him. The problem is:

We denote k!:

k! = 1 × 2 × ? × (k - 1) × k

We denote S:

S = 1 × 1! + 2 × 2! + ? + (n1)×(n1)!

Then S module n is ____________

You are given an integer n.

You have to calculate S modulo n.

Input

The first line contains an integer T(T1000), denoting the number of test cases.

For each test case, there is a line which has an integer n.

It is guaranteed that ≤ ≤ 1018.

Output

For each test case, print an integer S modulo n.

Hint

The first test is: × 11, and 1 modulo 2 is 1.

The second test is: × 1× 25 , and 5 modulo 3 is 2.

样例输入

2
2
3

样例输出

1
2

题意:

已知S = 1 × 1! + 2 × 2! + ? + (n1)×(n1)!,求S%n的值。

思路:

直接给结论吧,S%n=n-1

#include<iostream> 
using namespace std;
typedef long long ll;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        ll n;
        cin>>n;
        cout<<n-1<<endl;
    }
    return 0;
}

 

以上是关于2018ICPC南京网络赛 AAn Olympian Math Problem(数论题)的主要内容,如果未能解决你的问题,请参考以下文章

ACM-ICPC 2018 南京网络赛

ICPC2018南京网络赛 AC Challenge(一维状压dp)

2018 ICPC南京网络赛 Set(字典树 + 合并 + lazy更新)

2018ICPC南京赛区网络赛J Sum(素数筛+找规律)

2018-南京网络赛icpc-L题(分层最短路)

ICPC 2018 南京网络赛 J Magical Girl Haze(多层图最短路)