1100 Mars Numbers(20 分)

Posted wanghao-boke

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1100 Mars Numbers(20 分)相关的知识,希望对你有一定的参考价值。

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13
#include<iostream>
#include<string>
#include<map>
using namespace std;
string numTostr[170];
map<string,int> strTonum;
string unitDigit[13]={
    "tret", "jan", "feb","mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"
    };
string tenDigit[13] = {
   "tret","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"
};

void init(){
    for(int i = 0; i < 13; i++){
        strTonum[unitDigit[i]] = i;
        numTostr[i] = unitDigit[i];
        strTonum[tenDigit[i]] = i * 13;
        numTostr[i * 13] = tenDigit[i];
    }
    for(int i = 1; i < 13; i++){
        for(int j = 1; j < 13; j++){
            string str = tenDigit[i] + " " + unitDigit[j];
            numTostr[i * 13 + j] = str;
            strTonum[str] = i * 13 + j;
        }
    }
}

int main(){
    init();
    int n;
    scanf("%d%*c",&n);
    while(n--){
        string str;
        getline(cin,str);
        if(str[0] >= 0 && str[0] <= 9){
            int num = 0;
            for(int i = 0 ; i < str.length(); i++){
                num = num * 10 + (str[i] - 0);
            }
            cout << numTostr[num] << endl;
        }else{
            cout << strTonum[str] << endl;
        }
    }
    return 0;
}

 

以上是关于1100 Mars Numbers(20 分)的主要内容,如果未能解决你的问题,请参考以下文章

1100 Mars Numbers (20分)

1100 Mars Numbers(20 分)

1100 Mars Numbers (20分)

STL_A1100 Mars Numbers (20 分)

1100 Mars Numbers (20 分)难度: 一般 / 知识点: 模拟

PAT 1100 Mars Numbers