uva 10288 gailv

Posted 2014slx

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了uva 10288 gailv相关的知识,希望对你有一定的参考价值。

Problem F

Coupons

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

 

Coupons in cereal boxes are numbered 1 to n, and a set of one of each is required for a prize (a cereal box, of course). With one coupon per box, how many boxes on average are required to make a complete set ofn coupons?

Input

Input consists of a sequence of lines each containing a single positive integern, 1<=n<=33, giving the size of the set of coupons. Input is terminated by end of file.

Output

For each input line, output the average number of boxes required to collect the complete set ofn coupons. If the answer is an integer number, output the number. If the answer is not integer, then output the integer part of the answer followed by a space and then by the proper fraction in the format shown below. The fractional part should be irreducible. There should be no trailing spaces in any line of output.

Sample Input

2
5
17
Sample Output

3 
   5
11 --
   12
   340463
58 ------

 

记得每次求gcd不然会爆掉。 思路:到k张时。我们还有n-k张没有得到。所以我们得到的概率为n-k/n;

所以到k+1步的期望时n/n-k;

整理得 n* 1/i(n>i>1)的累加

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
#define ll long long
ll gcd(ll n,ll m)
{
    if(m==0)
        return n;
    return gcd(m,n%m);
}
int geth(ll x)
{
    int ans=0;
    while(x>0)
    {
        x=x/10;
        ans++;
    }
    return ans;
}
int main()
{
    ll  n;
    while(~scanf("%lld",&n))
    {
        
        ll fenmu=1;
        ll temp=1;
        for(int i=1;i<=n;i++)
        {
            temp=gcd(fenmu,i);
            fenmu=fenmu*i/temp;
        }
        ll fenzi=0;
        for(int i=1;i<=n;i++)
        {
            fenzi+=fenmu/i;
            
        }
        fenzi=fenzi*n;
        ll p=gcd(fenzi,fenmu);
        fenzi/=p;
        fenmu/=p;
        ll t=fenzi/fenmu;
        if(fenzi-fenmu*t>0)
        {
            if(t!=0)
            {
                ll a=geth(t);
                for(int i=0;i<=a;i++)
                {cout<<" ";}
                cout<<fenzi-fenmu*t;
                ll b=geth(fenzi-fenmu*t);
                ll c=geth(fenmu);
                if(b>c)
                    c=b;
                cout<<endl;
                cout<<t<<" ";
                for(int i=1;i<=c;i++)
                {cout<<"-";}
                cout<<endl;
                for(int i=0;i<=a;i++)
                {cout<<" ";}
                cout<<fenmu<<endl;
            }
        }
        else
            cout<<t<<endl;
        
    }
    
    
    return 0;
}

 

以上是关于uva 10288 gailv的主要内容,如果未能解决你的问题,请参考以下文章

UVa10288概率

UVA 10288 Coupons---概率 && 分数类模板

UVA 10288 Coupons (概率)

UVa 1442 - Cave

UVa10410代码

知识图谱系列教程