POJ 3268 Silver Cow Party

Posted wpbing

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 3268 Silver Cow Party相关的知识,希望对你有一定的参考价值。

Language:
Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 29299   Accepted: 13309

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow‘s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

从几个点 到x  再从x回来

这个有个小技巧  ,按照一般写会超时  各个点到一个点x的最短距离  可以换成x到各个点的,只需把矩阵反转一下再跑一遍图论算法就可以了

#include<iostream>
#include<string.h>
#include<algorithm>
#include<stdio.h>
#define inf 0x3f3f3f
using namespace std;
int map[1010][1010];
int dis[1010];
int dis1[1010];
int vis[1010];
int n,m,x;
void djst(int s)
{
    memset(vis,0,sizeof(vis));
    memset(dis,inf,sizeof(dis));
    
    dis[s]=0;
    while(1)
    {
        int k=-1,minn=inf;
        for(int i=1;i<=n;i++)
        {
            if(!vis[i]&&dis[i]<minn)
            k=i,minn=dis[i];
        }
        if(k==-1) break;
        vis[k]=1;
        for(int i=1;i<=n;i++)
        dis[i]=min(dis[i],dis[k]+map[k][i]);
    }

}
int main()
{
     while(scanf("%d %d %d",&n,&m,&x)!=EOF)
    {
        memset(map,inf,sizeof(map));
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(i==j) map[i][j]=0;
                else map[i][j]=inf;
            }
        }
        for(int i=0;i<m;i++)
        {
            int a,b,c;
            cin>>a>>b>>c;
            if(map[a][b]>c)
            map[a][b]=c;
        }
        djst(x);
        for(int i=1;i<=n;i++) dis1[i]=dis[i];
    
    /*    for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                cout<<map[i][j]<<"    ";
            }
            cout<<endl;
        }
        cout<<endl;
            for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                cout<<map[i][j]<<"    ";
            }
            cout<<endl;
        }
        */
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=i;j++)
            {
            swap(map[i][j],map[j][i]);
            }
        }
        int ans=0;
        djst(x);
        for(int i=1;i<=n;i++)
        {
        //    cout<<dis[i]<<" "<<dis1[i]<<endl;
            ans=max(ans,dis[i]+dis1[i]);
        }
        cout<<ans<<endl;
    }

    return 0;
 }

 


以上是关于POJ 3268 Silver Cow Party的主要内容,如果未能解决你的问题,请参考以下文章

POJ 3268 Silver Cow Party (Dijkstra)

POJ3268 Silver Cow Party —— 最短路

POJ 3268 Silver Cow Party

POJ 3268 Silver Cow Party

poj 3268 Silver Cow Party

POJ-3268 Silver Cow Party( 最短路 )