4 Values whose Sum is 0 POJ - 2785

Posted smallhester

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了4 Values whose Sum is 0 POJ - 2785相关的知识,希望对你有一定的参考价值。

4 Values whose Sum is 0
Time Limit: 15000MS   Memory Limit: 228000K
Total Submissions: 29243   Accepted: 8887
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n . 

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D . 

Output

For each input file, your program has to write the number quadruplets whose sum is zero. 

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30). 
 
题意:ABCD四个数列,每个数列抽一个数字,使得和为0,问一共有几组。当一个数列中有多个相同的数字时,把他们作为不同的数字看待。
思路:直接爆搜肯定会超时,将它们对半分成AB和CD再考虑就可以解决。比如在AB中取出a,b后,CD中要取出-a-b,因此先把CD中所有取数字的情况n*n种给纪录下来,然后排序,用二分查找次数。
 
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<set>
#include<vector>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-10
typedef long long ll;
const int maxn = 4002;
const int mod = 1e9 + 7;
int gcd(int a, int b) {
    if (b == 0) return a;  return gcd(b, a % b);
}

int n;
int a[maxn],b[maxn],c[maxn],d[maxn];
int cd[maxn*maxn];

void solve()
{
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        {
            cd[i*n+j]=c[i]+d[j];
        }
    sort(cd,cd+n*n);
    ll res=0;
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        {
            int ab=-(a[i]+b[j]);
            res+=upper_bound(cd,cd+n*n,ab)-lower_bound(cd,cd+n*n,ab);
        }
    cout<<res<<endl;
}
int main()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d %d %d %d",&a[i],&b[i],&c[i],&d[i]);
    
    solve();
}

 

以上是关于4 Values whose Sum is 0 POJ - 2785的主要内容,如果未能解决你的问题,请参考以下文章

4 Values whose Sum is 0(二分)

4 Values whose Sum is 0 (二分+排序)

poj 2785 4 Values whose Sum is 0

4 Values whose Sum is 0 :POJ - 2785

二分-G - 4 Values whose Sum is 0

4 Values whose Sum is 0 POJ - 2785