E - Heavy Transportation
Posted wzl19981116
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了E - Heavy Transportation相关的知识,希望对你有一定的参考价值。
来源poj1797
Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.
Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo‘s place) to crossing n (the customer‘s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4
要求你算出从1到n的道路,找出能运最大的重量,最大生成树,用了prim算法,额一开始没看到到n,以为是到任意一个地方,wa了
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include <iomanip>
#include<cmath>
#include<float.h>
#include<string.h>
#include<algorithm>
#define sf scanf
#define pf printf
#define mm(x,b) memset((x),(b),sizeof(x))
#include<vector>
#include<queue>
#include<stack>
#include<map>
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=a;i>=n;i--)
typedef long long ll;
const ll mod=1e9+100;
const double eps=1e-8;
using namespace std;
const double pi=acos(-1.0);
const int inf=0xfffffff;
const int N=1005;
int visit[N],Map[N][N],dist[N];
int prim(int n)
{
int pos,ans=inf;
rep(i,1,n+1)
dist[i]=Map[1][i];
visit[1]=1;
dist[1]=0;
rep(i,1,n+1)
{
int max1=-inf;
rep(j,1,n+1)
if(visit[j]==0&&dist[j]>max1)
{
max1=dist[j];
pos=j;
}
visit[pos]=1;
ans=min(max1,ans);
if(pos==n) break;
rep(j,1,n+1)
if(visit[j]==0&&dist[j]<Map[pos][j])
dist[j]=Map[pos][j];
}
return ans;
}
int main()
{
int re,cas=1,n,m,x,y,k;
cin>>re;
while(re--)
{
sf("%d%d",&n,&m);
mm(visit,0);
mm(Map,0);
mm(dist,0);
while(m--)
{
sf("%d%d%d",&x,&y,&k);
Map[x][y]=Map[y][x]=k;
}
pf("Scenario #%d:
%d
",cas++,prim(n));
}
// pf("
");
return 0;
}
以上是关于E - Heavy Transportation的主要内容,如果未能解决你的问题,请参考以下文章