2018HDU多校训练-3-Problem F. Grab The Tree

Posted songorz

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了2018HDU多校训练-3-Problem F. Grab The Tree相关的知识,希望对你有一定的参考价值。

Little Q and Little T are playing a game on a tree. There are n技术分享图片 vertices on the tree, labeled by 1,2,...,n技术分享图片 , connected by n?1技术分享图片 bidirectional edges. The i技术分享图片 -th vertex has the value of w技术分享图片i技术分享图片技术分享图片 .
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x技术分享图片 and y技术分享图片 , he can‘t grab both x技术分享图片 and y技术分享图片 . After Q‘s move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices‘ value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.
 

 

Input
The first line of the input contains an integer T(1T20)技术分享图片 , denoting the number of test cases.
In each test case, there is one integer n(1n100000)技术分享图片 in the first line, denoting the number of vertices.
In the next line, there are n技术分享图片 integers w技术分享图片1技术分享图片,w技术分享图片2技术分享图片,...,w技术分享图片n技术分享图片(1w技术分享图片i技术分享图片10技术分享图片9技术分享图片)技术分享图片 , denoting the value of each vertex.
For the next n?1技术分享图片 lines, each line contains two integers u技术分享图片 and v技术分享图片 , denoting a bidirectional edge between vertex u技术分享图片 and v技术分享图片 .
 

 

Output
For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.
 

 

Sample Input
1 3 2 2 2 1 2 1 3
 

 

Sample Output
Q
题解:由于是求异或,我们只需考虑每一位上的 1 的个数即可,比如:对于最高位,如果为偶数,那么小Q只需选一个或者不选即可那么小Q,小T最后该位上的数是相同的,如果为奇数,小Q选一个为必胜,因为小Q就选这一个,剩下都给小T,小T的最终结果必定小于小Q, 因此,我们只需要对每一位上的1的个数加一遍,如果有出现奇数个,则Q必胜,否者平局;
参考代码为:
 
#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int w[maxn],u[maxn],v[maxn];
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	
	int T,n;
	cin>>T;
	while(T--)
	{
		cin>>n;
		bool flag=false;
		for(int i=1;i<=n;i++) cin>>w[i];
		for(int i=1;i<n;i++) cin>>u[i]>>v[i];
		for(int i=0;i<32;i++)
		{
			int cnt=0;
			for(int i=1;i<=n;i++)
			{
				if(w[i]&1) cnt++;
				w[i]>>=1;
			}
			if(cnt & 1) 
			{
				cout<<"Q"<<endl;
				flag=true;
				break;
			}
		}
		if(!flag) cout<<"D"<<endl;	
	}
	
	return 0;
}

  








以上是关于2018HDU多校训练-3-Problem F. Grab The Tree的主要内容,如果未能解决你的问题,请参考以下文章

2018HDU多校训练-3-Problem D. Euler Function

[Lyndon分解] HDU 6761 Minimum Index (2020多校训练)

hdu 4911 Inversion(归并排序求逆序对数)2014多校训练第5场

2019HDU多校训练第五场1007-permutation 2

多校训练2HDU 6047 Maximum Sequence

HDU6621 K-th Closest Distance HDU2019多校训练第四场 1008(主席树+二分)