「CJOJ2574」Lucky Transformati

Posted cjgjh

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了「CJOJ2574」Lucky Transformati相关的知识,希望对你有一定的参考价值。

技术分享图片


Sample Input


7 2
2343223
4 1
2234

Sample Output


2243233
2334

技术分享图片


题解

这是一道找规律题,发现233->223->233->223...此时就可以写出正解.

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
#define file(a) freopen(a".in","r",stdin);freopen(a".out","w",stdout);
using namespace std;
inline int gi(){
    int f=1,sum=0;char ch=getchar();
    while(ch>'9' || ch<'0'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0' && ch<='9'){sum=sum*10+ch-'0';ch=getchar();}
    return f*sum;
}
const int maxn=1000000+10;
char s[maxn];
int main(){
    int i,j,k,n,m;
    while(scanf("%d %d
",&n,&k)!=EOF){
        scanf("%s",s);
        int len=strlen(s);
        for(i=0;i<len;i++){
            if(!k)break;
            if(s[i]=='2' && s[i+1]=='3'){
                k--;
                if((i+1)%2==1)s[i+1]='2';
                else{
                    s[i]='3';
                    if(s[i-1]=='2'){
                        if(k%2)s[i]='2';
                        break;
                    }
                }
            }
        }
        puts(s);
    }
    return 0;
}

以上是关于「CJOJ2574」Lucky Transformati的主要内容,如果未能解决你的问题,请参考以下文章

CJOJ 免费航班

CJOJ1857 -PG图

软件开发 [CJOJ 1101] [NOIP 模拟]

(CJOJ)P2634 - NOIP2017模拟失格

「CJOJ2736」「POJ1014」大理石分割

lucky 的 时光助理