04-树7 二叉搜索树的操作集 (30分)
Posted 2018shawn
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了04-树7 二叉搜索树的操作集 (30分)相关的知识,希望对你有一定的参考价值。
本题要求实现给定二叉搜索树的5种常用操作。
函数接口定义:
BinTree Insert( BinTree BST, ElementType X );
BinTree Delete( BinTree BST, ElementType X );
Position Find( BinTree BST, ElementType X );
Position FindMin( BinTree BST );
Position FindMax( BinTree BST );
其中BinTree
结构定义如下:
typedef struct TNode *Position; typedef Position BinTree; struct TNode{ ElementType Data; BinTree Left; BinTree Right; };
- 函数
Insert
将X
插入二叉搜索树BST
并返回结果树的根结点指针; - 函数
Delete
将X
从二叉搜索树BST
中删除,并返回结果树的根结点指针;如果X
不在树中,则打印一行Not Found
并返回原树的根结点指针; - 函数
Find
在二叉搜索树BST
中找到X
,返回该结点的指针;如果找不到则返回空指针; - 函数
FindMin
返回二叉搜索树BST
中最小元结点的指针; - 函数
FindMax
返回二叉搜索树BST
中最大元结点的指针。
裁判测试程序样例:
#include <stdio.h> #include <stdlib.h> typedef int ElementType; typedef struct TNode *Position; typedef Position BinTree; struct TNode{ ElementType Data; BinTree Left; BinTree Right; }; void PreorderTraversal( BinTree BT ); /* 先序遍历,由裁判实现,细节不表 */ void InorderTraversal( BinTree BT ); /* 中序遍历,由裁判实现,细节不表 */ BinTree Insert( BinTree BST, ElementType X ); BinTree Delete( BinTree BST, ElementType X ); Position Find( BinTree BST, ElementType X ); Position FindMin( BinTree BST ); Position FindMax( BinTree BST ); int main() { BinTree BST, MinP, MaxP, Tmp; ElementType X; int N, i; BST = NULL; scanf("%d", &N); for ( i=0; i<N; i++ ) { scanf("%d", &X); BST = Insert(BST, X); } printf("Preorder:"); PreorderTraversal(BST); printf(" "); MinP = FindMin(BST); MaxP = FindMax(BST); scanf("%d", &N); for( i=0; i<N; i++ ) { scanf("%d", &X); Tmp = Find(BST, X); if (Tmp == NULL) printf("%d is not found ", X); else { printf("%d is found ", Tmp->Data); if (Tmp==MinP) printf("%d is the smallest key ", Tmp->Data); if (Tmp==MaxP) printf("%d is the largest key ", Tmp->Data); } } scanf("%d", &N); for( i=0; i<N; i++ ) { scanf("%d", &X); BST = Delete(BST, X); } printf("Inorder:"); InorderTraversal(BST); printf(" "); return 0; } /* 你的代码将被嵌在这里 */
输入样例:
10 5 8 6 2 4 1 0 10 9 7 5 6 3 10 0 5 5 5 7 0 10 3
输出样例:
Preorder: 5 2 1 0 4 8 6 7 10 9 6 is found 3 is not found 10 is found 10 is the largest key 0 is found 0 is the smallest key 5 is found Not Found Inorder: 1 2 4 6 8 9
提交测试代码:
BinTree Insert(BinTree BST, ElementType X) { if (!BST) { BST = (BinTree)malloc(sizeof(struct TNode)); BST->Data = X; BST->Left = NULL; BST->Right = NULL; } else if (BST->Data > X) { BST->Left = Insert(BST->Left, X); } else if (BST->Data < X) { BST->Right = Insert(BST->Right, X); } return BST; } BinTree Delete(BinTree BST, ElementType X) { if (!BST) { printf("Not Found "); } else if (BST->Data > X) { BST->Left = Delete(BST->Left, X); } else if (BST->Data < X) { BST->Right = Delete(BST->Right, X); } else if (BST->Left != NULL && BST->Right == NULL) { BinTree tmp = BST; BST = BST->Left; free(tmp); } else if (BST->Left == NULL && BST->Right != NULL) { BinTree tmp = BST; BST = BST->Right; free(tmp); } else if (BST->Left == NULL && BST->Right == NULL) { free(BST); BST = NULL; } else { Position tmp = FindMin(BST->Right); BST->Data = tmp->Data; BST->Right = Delete(BST->Right, BST->Data); } return BST; } Position Find(BinTree BST, ElementType X) { if (!BST) { return NULL; } else if (BST->Data > X) { return Find(BST->Left, X); } else if (BST->Data < X) { return Find(BST->Right, X); } else { return BST; } } Position FindMin(BinTree BST) { if (!BST) { return NULL; } else if (BST->Left != NULL) { return FindMin(BST->Left); } else { return BST; } } Position FindMax(BinTree BST) { if (!BST) { return NULL; } else if (BST->Right != NULL) { return FindMax(BST->Right); } else { return BST; } }
提测结果:
完整自测代码:
#include <stdio.h> #include <stdlib.h> typedef int ElementType; typedef struct TNode *Position; typedef Position BinTree; struct TNode { ElementType Data; BinTree Left; BinTree Right; }; void PreorderTraversal(BinTree BT); /* 先序遍历,由裁判实现,细节不表 */ void InorderTraversal(BinTree BT); /* 中序遍历,由裁判实现,细节不表 */ BinTree Insert(BinTree BST, ElementType X); BinTree Delete(BinTree BST, ElementType X); Position Find(BinTree BST, ElementType X); Position FindMin(BinTree BST); Position FindMax(BinTree BST); int main() { BinTree BST, MinP, MaxP, Tmp; ElementType X; int N, i; BST = NULL; scanf("%d", &N); for (i = 0; i < N; i++) { scanf("%d", &X); BST = Insert(BST, X); } printf("Preorder:"); PreorderTraversal(BST); printf(" "); MinP = FindMin(BST); MaxP = FindMax(BST); scanf("%d", &N); for (i = 0; i < N; i++) { scanf("%d", &X); Tmp = Find(BST, X); if (Tmp == NULL) printf("%d is not found ", X); else { printf("%d is found ", Tmp->Data); if (Tmp == MinP) printf("%d is the smallest key ", Tmp->Data); if (Tmp == MaxP) printf("%d is the largest key ", Tmp->Data); } } scanf("%d", &N); for (i = 0; i < N; i++) { scanf("%d", &X); BST = Delete(BST, X); } printf("Inorder:"); InorderTraversal(BST); printf(" "); return 0; } void PreorderTraversal(BinTree T){ if (!T) { return; } printf(" %d", T->Data); if(T->Left){ PreorderTraversal(T->Left); } if (T->Right){ PreorderTraversal(T->Right); } } void InorderTraversal(BinTree T) { if (!T) { return; } if (T->Left) { InorderTraversal(T->Left); } printf(" %d", T->Data); if (T->Right) { InorderTraversal(T->Right); } } BinTree Insert(BinTree BST, ElementType X) { if (!BST) { BST = (BinTree)malloc(sizeof(struct TNode)); BST->Data = X; BST->Left = NULL; BST->Right = NULL; } else if (BST->Data > X) { BST->Left = Insert(BST->Left, X); } else if (BST->Data < X) { BST->Right = Insert(BST->Right, X); } return BST; } BinTree Delete(BinTree BST, ElementType X) { if (!BST) { printf("Not Found "); } else if (BST->Data > X) { BST->Left = Delete(BST->Left, X); } else if (BST->Data < X) { BST->Right = Delete(BST->Right, X); } else if (BST->Left != NULL && BST->Right == NULL) { BinTree tmp = BST; BST = BST->Left; free(tmp); } else if (BST->Left == NULL && BST->Right != NULL) { BinTree tmp = BST; BST = BST->Right; free(tmp); } else if (BST->Left == NULL && BST->Right == NULL) { free(BST); BST = NULL; } else { Position tmp = FindMin(BST->Right); BST->Data = tmp->Data; BST->Right = Delete(BST->Right, BST->Data); } return BST; } Position Find(BinTree BST, ElementType X) { if (!BST) { return NULL; } else if (BST->Data > X) { return Find(BST->Left, X); } else if (BST->Data < X) { return Find(BST->Right, X); } else { return BST; } } Position FindMin(BinTree BST) { if (!BST) { return NULL; } else if (BST->Left != NULL) { return FindMin(BST->Left); } else { return BST; } } Position FindMax(BinTree BST) { if (!BST) { return NULL; } else if (BST->Right != NULL) { return FindMax(BST->Right); } else { return BST; } }
以上是关于04-树7 二叉搜索树的操作集 (30分)的主要内容,如果未能解决你的问题,请参考以下文章