PTA(BasicLevel)-1016 部分A+B

Posted justlittlestar

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PTA(BasicLevel)-1016 部分A+B相关的知识,希望对你有一定的参考价值。

一、问题定义

       正整数 a的“Da(为 1 位整数)部分”定义为由a中所有Da组成的新整数Pa?。如:给定8,Da = 6,则a的“6 部分”Pa是66,因为a中有 2个6。现给定a、Da、b、Db,请编写程序计算 Pa + Pb。

输入格式:
输入在一行中依次给出 a、Da??、b、Db??,中间以空格分隔,其中 0。

输出格式:
在一行中输出 Pa??+P?b?? 的值。

 

输入样例 1:

3862767 6 13530293 3

输出样例 1:
399
 
输入样例 2:
3862767 1 13530293 8
 
输出样例 2:
0
 

二、解题

def num_generate( cnt, base ):
    # cnt, base both are integer
    figure = 0
    if 9 >= base > 0:
        while cnt > 0:
            figure = figure*10 + base
            cnt -= 1
    return figure
    
numbers = input()
num_a, a, num_b, b = [  n for n in numbers.split(" ")]
#print(num_a, a, num_b, b)

Pa =  num_generate( num_a.count(a), int(a))
Pb =  num_generate( num_b.count(b), int(b))
print(Pa+Pb)

 

以上是关于PTA(BasicLevel)-1016 部分A+B的主要内容,如果未能解决你的问题,请参考以下文章

PTA(Basic Level)1016.部分A+B

PTA 乙级 1016 部分A+B (15分)

PTA(BasicLevel)-1009 说反话

PTA-1016——Phone Bills

从头开始之PTA

1016 部分A+B