POJ - 3984 迷宫问题

Posted shiyu-coder

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ - 3984 迷宫问题相关的知识,希望对你有一定的参考价值。

题目:

定义一个二维数组:

int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路:

很水的一道题,直接BFS就行了,路径我是用int变量(十位是x,个位是y)直接记录到结构体里

代码:
#include<iostream>
#include<queue>
#include<vector>
#include<string>
using namespace std;

struct Pos{
    int x,y;
    vector<int> history; //经过的区域,由于迷宫宽度为5,所以直接用10位记录x,个位记录y
};

const int L=5; //迷宫规格
int m[L][L]={0}; //迷宫
queue<Pos> q; //BFS队列

int main(){
    for(int i=0;i<L;i++){
        for(int j=0;j<L;j++){
            cin >>m[i][j];
        }
    }

    int X[]={-1,1,0,0};
    int Y[]={0,0,-1,1};

    //BFS
    Pos begin;
    begin.x=0;begin.y=0;
    begin.history.push_back(begin.x*10+begin.y);
    q.push(begin);
    while(!q.empty()){
        Pos p=q.front();
        q.pop();
        if(p.x==L-1&&p.y==L-1){
            //打印路径
            for(int i=0;i<p.history.size();i++){
                cout <<"("<<p.history[i]/10<<", "<<p.history[i]%10<<")"<<endl;
            }
            break;
        }
        for(int i=0;i<4;i++){
            Pos pp;
            pp.x=p.x+X[i];pp.y=p.y+Y[i];
            pp.history=p.history;
            pp.history.push_back(pp.x*10+pp.y);
            if(pp.x>=0&&pp.x<L&&pp.y>=0&&pp.y<L&&m[pp.x][pp.y]==0){
                m[pp.x][pp.y]=1;
                q.push(pp);
            }
        }
    }
    system("pause");
    return 0;
}

 

以上是关于POJ - 3984 迷宫问题的主要内容,如果未能解决你的问题,请参考以下文章

POJ3984:迷宫问题(水)

POJ 3984 迷宫问题

poj 3984 迷宫问题

POJ_3984_迷宫问题 DFS

poj 3984 迷宫问题

poj 3984 迷宫问题