大数统计问题
Posted banyouxia
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了大数统计问题相关的知识,希望对你有一定的参考价值。
统计数字
Description
某次科研调查时得到了n个自然数,每个数均不超过1500000000(1.5*109)。已知不相同的数不超过10000个,现在需要统计这些自然数各自出现的次数,并按照自然数从小到大的顺序输出统计结果。
Input
输入文件count.in包含n+1行:
第1行是整数n,表示自然数的个数。
第2~n+1行每行一个自然数。
Output
输出文件count.out包含m行(m为n个自然数中不相同数的个数),按照自然数从小到大的顺序输出。每行输出两个整数,分别是自然数和该数出现的次数,其间用一个空格隔开。
Sample Input
Sample Output
HINT
40%的数据满足:1<=n<=1000
80%的数据满足:1<=n<=50000
100%的数据满足:1<=n<=200000,每个数均不超过1 500 000 000(1.5*109)
解题思路:使用map作为一对一的统计,(了解map的使用和好处)。
代码如下:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<math.h>
#include<map>
using namespace std;
#define maxn 1000000
#define INF 10000000000
int main(){
int n,m;
cin >> n;
map<int,int> a;
while(n--){
cin >> m;
a[m]++;
}
map<int,int>::iterator iter;
for(iter = a.begin();iter!=a.end();iter++){
cout << iter->first << " " << iter->second << endl;
}
}
以上是关于大数统计问题的主要内容,如果未能解决你的问题,请参考以下文章