POJ 1004

Posted fantastic123

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 1004相关的知识,希望对你有一定的参考价值。

Financial Management

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 196088   Accepted: 74533

Description

Larry graduated this year and finally has a job. He‘s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what‘s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42

注意最后输出加$和保留两位小数

#include <iostream>
#include<iomanip>
using namespace std;
 
int main()
{
    
    double a[12];
    double sum=0;
    for(int i=0;i<12;i++)
    {
    cin>>a[i];
    sum+=a[i];
    }
    double res=sum/(12.0);
    cout<<fixed<<setprecision(2)<<"$"<<res<<endl; 
}
 

 

以上是关于POJ 1004的主要内容,如果未能解决你的问题,请参考以下文章

poj1004

POJ 1004 Financial Management

poj 1004(水题)

POJ 1004

[poj 1004]Financial Management

poj1004