PAT 1043 输出PATest

Posted zlrrrr

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 1043 输出PATest相关的知识,希望对你有一定的参考价值。

https://pintia.cn/problem-sets/994805260223102976/problems/994805280074743808

 

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest....”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

redlesPayBestPATTopTeephpereatitAPPT

输出样例:

PATestPATestPTetPTePePee
 
代码:
#include <bits/stdc++.h>

using namespace std;

const int maxn=1e5+10;
char a[10]= {‘ ‘,‘P‘,‘A‘,‘T‘,‘e‘,‘s‘,‘t‘};
char s[maxn];
int num[10];

int main()
{
    scanf("%s",s);
    int len=strlen(s);
    for(int i=0; i<len; i++)
    {
        if(s[i]==‘P‘)
            num[1]++;
        if(s[i]==‘A‘)
            num[2]++;
        if(s[i]==‘T‘)
            num[3]++;
        if(s[i]==‘e‘)
            num[4]++;
        if(s[i]==‘s‘)
            num[5]++;
        if(s[i]==‘t‘)
            num[6]++;
    }
    for(int j=0;j<maxn;j++)
    {
         for(int i=1; i<=6; i++)
        {
        //cout<<num[i]<<endl;
            if(num[i]>0)
            {
                printf("%c",a[i]);
                num[i]--;
            }
            continue;
        }
    }
    return 0;
}

  

以上是关于PAT 1043 输出PATest的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1043 输出PATest

PAT B1043 输出PATest

PAT乙级1043 输出PATest (20 分)

[PAT乙级]1043 输出PATest

PAT Basic 1043 输出PATest (20 分)

PAT (Basic Level) Practice (中文)1043 输出PATest (20 分)