Pop Sequeue

Posted 熊猫耳朵

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Pop Sequeue相关的知识,希望对你有一定的参考价值。

题目描述

  Given a stack which can keep M numbers at most. Push N numbers in the order of 1,2,3...,N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1,2,3,4,5,6,7 from the stack, but not 3,2,1,7,5,6,4.

输入格式

  Each input file contains one test case. For each case, the first line contains 3 numbers(all no more than 1000): M(the maximum capacity of the stack), N(the length of push sequence), and K(the number of pop sequence to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

输出格式

  For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if else.

输入样例
5 7 3
1 2 3 4 5 6 7
3 2 1 7 5 6 4
5 6 4 3 7 2 1

输出样例
YES
NO
YES 

 

 

 

题意

  有一个容量限制为M的栈,先分别把1,2,3,n依次入栈,并给出一系列出栈顺序,问这些出栈顺序是否可能?

思路

  按照题目的要求进行模拟,将1~n依次入栈,在入栈的过程中如果入栈的元素恰好等于出栈序列当前等待出栈的元素,那么就让栈顶元素出栈,同时把出栈序列当前等待出栈的元素位置标记后移1位。此时只要栈顶元素依然等于出栈序列当前等待出栈的元素,则继续出栈。

代码

 #include<iostream>
 #include<stack>
 using namespace std;
 const int maxn = 1010;
 int arr[maxn];    //保存题目给的出栈序列 
 stack<int> st;    //定义栈st,用以存放int型元素
 int main()
 
     int m, n, T;    
     cin>>m>>n>>T;
     while(T--)        //循环T次 
         while(!st.empty())    //清空栈 
             st.pop();
         for(int i=1;i<=n;i++)    //读入数据 
             cin>>arr[i]; 
         int current = 1;    //指向出栈序列中的待出栈元素
         bool flag = true; 
         for(int i=1;i<=n;i++)
             st.push(i);        //把i压入栈
             if(st.size()>m)    //如果此时栈中元素个数大于容量m,则序列非法 
                 flag=false;
                 break;
             
             //栈顶元素与出栈序列当前位置的元素相同时 
             while(!st.empty()&&st.top()==arr[current])
                 st.pop();    //反复弹栈并令current++ 
                 current++;
              
         
         if(st.empty()==true&&flag==true)
             cout<<"TES"<<endl;
         
         else
             cout<<"NO"<<endl;
         
     
     return 0;
  

 

以上是关于Pop Sequeue的主要内容,如果未能解决你的问题,请参考以下文章

FragmentManager popBackStack 不删除片段

质量与效率:POP平台代码质量提升计划总结

《Linux内核 核心知识全解析(完)》

微信小程序代码片段

VSCode自定义代码片段——CSS选择器

谷歌浏览器调试jsp 引入代码片段,如何调试代码片段中的js