1113. 红与黑

Posted magic_zk

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1113. 红与黑相关的知识,希望对你有一定的参考价值。

题目描述

地砖有红和黑两种颜色,站在给定的某个黑色地砖上,问有多少块黑色地砖可达?

f1 dfs计算连通性

基本分析

  1. dfs返回什么?从当前节点出发可达的黑色地砖个数
  2. dfs怎么实现?
    • 初始化cnt;
    • 修改vis状态;
    • 枚举可选的4相邻地砖(越界跳过,访问过跳过,红色跳过,累加下一步可达的个数)
    • 返回cnt

代码

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int N = 25;

int m, n;

int dx[4] = 1, 0, -1, 0, dy[4] = 0, 1, 0, -1;
bool vis[N][N];
char g[N][N];


int dfs(int x, int y)

    int cnt = 1;
    
    vis[x][y] = true;
    
    for (int i = 0; i < 4; i++)
    
        int nx = x + dx[i], ny = y + dy[i];
        if (g[nx][ny] == \'#\') continue;
        if ( nx < 0 || nx >= n || ny < 0 || ny >= m) continue;
        if (vis[nx][ny]) continue;
        cnt += dfs(nx, ny);
    
    
    return cnt;


int main()

    while (cin >> m >> n, m || n)
    
        for (int i = 0; i < n; i++) cin >> g[i];
        
        int x, y;
        for (int i = 0; i < n; i++)
            for (int j = 0; j < m; j++)
                if (g[i][j] == \'@\')
                    x = i, y = j;
                    
        memset(vis, 0, sizeof vis);
        cout << dfs(x, y) << endl;
    
    
    return 0;

总结

  1. 这里n和m不同,怎么定义g和vis?直接给一个大的N
  2. 这里m和n的含义?m是横向,n是纵向。放到坐标中向右是y,向下是x
  3. 不能忘记初始化vis数组

红与黑

传送门

2806 红与黑

 时间限制: 1 s
 空间限制: 64000 KB
 题目等级 : 白银 Silver
 
 
题目描述 Description

有一个矩形房间,覆盖正方形瓷砖。每块瓷砖涂成了红色或黑色。一名男子站在黑色的瓷砖上,由此出发,可以移到四个相邻瓷砖之一,但他不能移动到红砖上,只能移动到黑砖上。编写一个程序,计算他通过重复上述移动所能经过的黑砖数。

 

输入描述 Input Description

输入包含多个数据集。一个数据集开头行包含两个正整数W和H,W和H分别表示矩形房间的列数和行数,且都不超过20.
每个数据集有H行,其中每行包含W个字符。每个字符的含义如下所示:
‘.‘——黑砖
‘#‘——红砖
‘@‘——男子(每个数据集仅出现一次)
两个0表示输入结束。

输出描述 Output Description

对每个数据集,程序应该输出一行,包含男子从初始瓷砖出发可到达的瓷砖数。

样例输入 Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#[email protected]#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
[email protected]
###.###
..#.#..
..#.#..
0 0

样例输出 Sample Output

45
59
6
13

数据范围及提示 Data Size & Hint

【思路】

广搜

【code】

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue> 
using namespace std;
char a[21][21];
int boo[21][21];
bool vis[22][22];
int dx[4]={0,1,-1,0},
    dy[4]={1,0,0,-1};
int h,w,ans,x,y; 
bool ok(int x,int y)
{
    if(x>=1&&x<=h&&y>=1&&y<=w)return 1;
    return 0;
}
void bfs(int x,int y)
{
    queue <int> qx;
    queue <int> qy;
    qx.push(x);qy.push(y);
    while(!qx.empty())
    {
        int nowx=qx.front();qx.pop();
        int nowy=qy.front();qy.pop();
        ans++;vis[nowx][nowy]=1;
        for(int i=0;i<4;i++)
        {
            int xx=nowx+dx[i],yy=nowy+dy[i];
            if(boo[xx][yy]&&!vis[xx][yy]&&ok(xx,yy))
            {
                qx.push(xx);qy.push(yy);  
                vis[xx][yy]=1;
            }
        }
    }  
}
int main()
{
    while(scanf("%d%d",&w,&h)&&w&&h)
    {
        ans=0;
        memset(boo,0,sizeof(boo));
        memset(vis,0,sizeof(vis));
        for(int i=0;i<h;i++)
        {
            scanf("%s",a[i]);
            for(int j=0;j<w;j++)
            {
                if(a[i][j]==.)
                boo[i+1][j+1]=1;
                if(a[i][j]==@)
                {
                    boo[i+1][j+1]=1;
                    x=i+1;y=j+1;
                }
            }
        }
        bfs(x,y);
        printf("%d\n",ans);
    }
    return 0;
}

 

以上是关于1113. 红与黑的主要内容,如果未能解决你的问题,请参考以下文章

AcWing 1113. 红与黑 (BFS DFS)

[dfs] aw1113. 红与黑(dfs连通性模型+dfs计数方式+模板题)

寒假每日一题(入门组)week2 完结

简单搜索 红与黑:

红与黑

红与黑