C++中怎样用递归来输出三角形数列。如图。。

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了C++中怎样用递归来输出三角形数列。如图。。相关的知识,希望对你有一定的参考价值。

*
***
*****
*******

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
void DrawTriangle(int nLine,int nAll)

if (nLine >= nAll)
return;
int nBeg = fabs(nAll - nLine-1);
for (int i = 0; i < nBeg; i++)
printf(" ");
for (i = nBeg;i< 2*nAll-(nBeg+1);i++)
printf("*");
if (nLine < nAll)

printf("\n");
DrawTriangle(nLine+1,nAll);


void main()

DrawTriangle(0,4);
system("pause");
参考技术A #include "stdafx.h"
#include<iostream>
using namespace std;
void main()

int n;
n=5;
for(int i=1;i<=n;i++)
for(int j=1;j<=2*n-1;j++)

if(j>n-i&&j<n+i)
cout<<"*";
else if(j<=n-i)
cout<<" ";
else if(j==n+i)

cout<<endl;
break;


cout<<endl;

(蓝桥杯)试题 算法训练 递归输出数字三角形

试题 算法训练 递归输出数字三角形

资源限制
时间限制:1.0s 内存限制:256.0MB
问题描述
  输出一个n行的与样例类似的数字三角形,必须使用递归来实现
输入格式
  一个正整数数n,表示三角形的行数
输出格式
  输出一个与样例类似的n行的数字三角形,同一行每两个数之间用一个空格隔开即可(图中只是为防止题面格式化而用’_'代替空格)
样例输入
4
样例输出
___1
__2_3
_4_5_6
7_8_9_10
数据规模和约定
  n<=20

非递归解法:

import java.util.Scanner;

public class Main{
    public static void main(String[] args){
        Scanner input = new Scanner(System.in) ;
        int n = input.nextInt() ;
        int count = 1;
        boolean flag = true ;
        for(int i=1; i<=n; i++){
            for(int j=1; j<=i; j++) {
                if(flag) {
                    for (int k = i; k < n; k++) {
                        System.out.print(" ");
                    }
                    flag = false ;
                }
                System.out.print(count + " ");
                count++;
            }
            System.out.println() ;
            flag = true ;
        }
    }
}

递归解法:

import java.util.Scanner;

public class Main {
    public static void runRecursiveMethod(int x, int max, int count, int n ) {
        boolean flag = true ;
        if(count>max)return;
        for(int i=0;i<x;i++) {
            if(flag) {
                for (int j = x; j < n; j++) {
                    System.out.print(" ");
                }
                flag = false ;
            }
            System.out.print((count++)  + " ");
        }
        System.out.println();
        flag = true ;
        runRecursiveMethod(++x,max,count++, n);
    }

    public static void main(String[] args){
        Scanner input = new Scanner(System.in) ;
        int n = input.nextInt() ;
        int [] arr = new int [n] ;
        runRecursiveMethod(1,(n*(n+1) / 2), 1, n) ;
    }
}

以上是关于C++中怎样用递归来输出三角形数列。如图。。的主要内容,如果未能解决你的问题,请参考以下文章

(蓝桥杯)试题 算法训练 递归输出数字三角形

JS:递归基础及范例——斐波那契数列 杨辉三角

c++输出三角形

怎样用java打印杨辉三角,自己输入行

C++向量在递归函数中丢失数据

c++编写程序输出五行的杨辉三角