7-45 jmu-python-涨工资 (10 分)
Posted 暧迷路
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了7-45 jmu-python-涨工资 (10 分)相关的知识,希望对你有一定的参考价值。
输入一组工资数据,写入列表。对于小于5000的工资,涨1.5倍。并输出涨后的工资数据。
输入格式:
数据之间空格隔开
输出格式:
涨工资后的数据,空格隔开。尾部 不带空格。
输入样例:
3000 4000 6000 8000 2000.5
输出样例:
4500.0 6000.0 6000 8000 3000.75
s = input() ls = [] ls = s.split() cnt = 0 for i in ls: i = float(i) if i <= 5000 and cnt == 1: if i - int(i) > 0: print(" {:.2f}".format(i * 1.5), end="") else : print(" {:.1f}".format(i*1.5),end="") elif i > 5000 and cnt == 1: print(" {:d}".format(int(i)),end="") if cnt == 0: if i <= 5000: if i - int(i) > 0: print("{:.2f}".format(i * 1.5), end="") cnt = 1 else: print("{:.1f}".format(i * 1.5), end="") cnt = 1 else: print("{:d}".format(int(i)), end="") cnt = 1
以上是关于7-45 jmu-python-涨工资 (10 分)的主要内容,如果未能解决你的问题,请参考以下文章