Problem D

Posted tansanity

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Problem D相关的知识,希望对你有一定的参考价值。

Problem Description A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. <br><br>Write a program to find and print the nth element in this sequence<br>  
Input The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.<br>  
Output For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.<br>  
Sample Input
  
   1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

  
 
Sample Output
  
   The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

  
 

简单题意:

  由质数2、3、5、7组成的数字称之为丑数,并且规定1为第一个丑数,现在需要编写一个程序,给出一个数字,输出以这个数字为序号的丑数。

解题思路形成过程;

  状态方程不难想,就是四者取其小,我们令2*a[p1],3*a[p2],5*a[p3],7*a[p4]。如果当前的值a[n]==四者中的其中一个,则令pi++;这样就能得出最终的结果。

感想:

  思路确定是没有一丝错误的,但是开始提交的时候一直Time LImit Exceed,试了3种方法,最后我先把所有的5842个丑数都求出来,放到一个数组中,然后调用。这样就不超时了。还有一个有趣的点,就是输出格式,1、2、3为st、nd、rd,其余的为th,并且十一十二十三的序数词也为th.所以加的限定条件就得多一条,n%100!=11||12||13。

AC代码:

// ConsoleApplication1.cpp : 定义控制台应用程序的入口点。
#include "iostream"
#include "cstdio"
int min(int a,int b,int c,int d)

    int e=a<b?a:b;
    int f=c<d?c:d;
    return e<f?e:f;

int humb[5842],a[5842];
using namespace std;
int main()

    int n=1;
    int p2,p3,p5,p7;
    p2=p3=p5=p7=1;
    a[1]=1;
    while(a[n]<2000000000)
   
        a[++n] = min(2*a[p2],3*a[p3],5*a[p5],7*a[p7]);
        if(a[n]==2*a[p2]) p2++;
        if(a[n]==3*a[p3]) p3++;
        if(a[n]==5*a[p5]) p5++;
        if(a[n]==7*a[p7]) p7++;
   
    while(scanf("%d",&n)&&n!=0)
   
        if(n%10==1&&n%100!=11)
        printf("The %dst humble number is %d.\\n",n,a[n]);
        else if(n%10==2&&n%100!=12)printf("The %dnd humble number is %d.\\n",n,a[n]);
        else if(n%10==3&&n%100!=13)printf("The %drd humble number is %d.\\n",n,a[n]);
        else printf("The %dth humble number is %d.\\n",n,a[n]);
   
    return 0;

以上是关于Problem D的主要内容,如果未能解决你的问题,请参考以下文章

codeforces 1288D. Minimax Problem(二分)

[HAOI2011]Problem b

D - Maximum Value Problem FZU - 2037

1107 回文数猜想

Codeforces 776D.The Door Problem (dfs二分图判定 / 并查集)

798C - Mike and gcd problem