Problem Q
Posted tansanity
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Problem Q相关的知识,希望对你有一定的参考价值。
Problem Description Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …<br>The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?<br><center><img src=../../../data/images/C154-1003-1.jpg> </center><br>Input The first line contain a integer T , the number of cases.<br>Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output One integer per line representing the maximum of the total value (this number will be less than 2<sup>31</sup>).
Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
Sample Output
14
简单题意: 很久之前,有一个骨头收集者,当然不同的骨头拥有不同的价值和体积。现在他背着一个拥有V容量的包裹从小镇出发,在路途中给出骨头的价值。现在需要编写一个程序,是价值达到最大。输入有三行,第一行是骨头的数目和背包的容量V,第二行是骨头的价值,第三行是骨头的体积。输出最大的总价值。 解题思路形成过程: 这是典型的01背包问题,对于每一块骨头。可以选择放进包里或者不。01背包的状态转移方程为:dp[i][v]=maxdp[i-1][v],dp[i-1][v-cost[i]]+value[i]; 感想: 01背包上课刚讲完现在就有了用武之地。动态规划还是有很多子类别的。 AC代码: #include<iostream>
#include <cstring>
using namespace std;
#define Size 1001
int va[Size],vo[Size];
int dp[Size];
int Max(int x,int y)
return x>y?x:y;
int main()
int t,n,v,i,j;
cin>>t;
while(t--)
cin>>n>>v;
for(i=1;i<=n;i++)
cin>>va[i];
for(i=1;i<=n;i++)
cin>>vo[i];
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
for(j=v;j>=vo[i];j--)
dp[j]=Max(dp[j],dp[j-vo[i]]+va[i]);
cout<<dp[v]<<endl;
return 0;
以上是关于Problem Q的主要内容,如果未能解决你的问题,请参考以下文章