poj.1654Area(计算几何)

Posted SSL_LKJ

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj.1654Area(计算几何)相关的知识,希望对你有一定的参考价值。

Area

题目传送门
Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.
Output

For each polygon, print its area on a single line.

输入样例

4
5
825
6725
6244865

输出样例

0
0
0.5
2

解题思路

记录坐标求面积

AC代码

#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
int nowx,nowy;
char s[1000005];
long long cj(int x1,int y1,int x2,int y2)

	return x1*y2-x2*y1;

void work(char ch)

	if(ch<'4')nowx++;
	if(ch>'6')nowx--;
	if(ch=='3'||ch=='6'||ch=='9')nowy++;
	if(ch=='1'||ch=='4'||ch=='7')nowy--;
	if(ch=='5')nowx=nowy=0;
	return;

int main()

	int T;
	scanf("%d",&T);
	while(T--)
	
		scanf("%s",&s);
		int x=0,y=0,len=strlen(s);;
		long long ans=0;
		for(int i=1;i<=len;i++)
		
			nowx=x,nowy=y;
			work(s[i]);
			ans+=cj(x,y,nowx,nowy);
			x=nowx,y=nowy;
		
		if(ans<0)ans=-ans;
		if(ans%2)printf("%lld.5\\n",ans/2);
		else printf("%lld\\n",ans/2);
	
	return 0;

谢谢

以上是关于poj.1654Area(计算几何)的主要内容,如果未能解决你的问题,请参考以下文章

poj.1654Area(计算几何)

poj1654-Area

poj1654 Area

POJ 1654 Area

POJ1654 Area(多边形面积)

poj 1654 Area(多边形面积)