HDU2859 Phalanx (DP)
Posted 松子茶
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU2859 Phalanx (DP)相关的知识,希望对你有一定的参考价值。
Phalanx
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1093 Accepted Submission(s): 522
Problem Description Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix:
cbx
cpb
zcc
Input There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.
Output Each test case output one line, the size of the maximum symmetrical sub- matrix.
Sample Input
3 abx cyb zca 4 zaba cbab abbc cacq 0
Sample Output
3 3
Source 2009 Multi-University Training Contest 5 - Host by NUDT
Recommend gaojie
对于每个字符看该列以上和该行右侧的字符匹配量,如果匹配量大于右上角记录下来的矩阵大小,就是右上角的数值+1,否则就是这个匹配量。
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
int dp[1010][1010];
char str[1010][1010];
int main()
int n;
while(scanf("%d",&n) == 1 && n)
for(int i = 0;i < n;i++)
scanf("%s",str[i]);
int ans = 1;
for(int i = 0;i < n;i++)
for(int j = 0;j < n;j++)
if(i == 0 || j == n-1)
dp[i][j] = 1;
continue;
int t1 = i, t2 = j;
while(t1 >= 0 && t2 < n && str[t1][j] == str[i][t2])
t1--;
t2++;
t1 = i - t1;
if(t1 >= dp[i-1][j+1]+1)dp[i][j] = dp[i-1][j+1]+1;
else dp[i][j] = t1;
ans = max(ans,dp[i][j]);
printf("%d\\n",ans);
return 0;
以上是关于HDU2859 Phalanx (DP)的主要内容,如果未能解决你的问题,请参考以下文章