POJ1603 ZOJ1221 RiskFloyd算法
Posted 海岛Blog
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ1603 ZOJ1221 RiskFloyd算法相关的知识,希望对你有一定的参考价值。
Risk
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3537 Accepted: 1580
Description
Risk is a board game in which several opposing players attempt to conquer the world. The gameboard consists of a world map broken up into hypothetical countries. During a player’s turn, armies stationed in one country are only allowed to attack only countries with which they share a common border. Upon conquest of that country, the armies may move into the newly conquered country.
During the course of play, a player often engages in a sequence of conquests with the goal of transferring a large mass of armies from some starting country to a destination country. Typically, one chooses the intervening countries so as to minimize the total number of countries that need to be conquered. Given a description of the gameboard with 20 countries each with between 1 and 19 connections to other countries, your task is to write a function that takes a starting country and a destination country and computes the minimum number of countries that must be conquered to reach the destination. You do not need to output the sequence of countries, just the number of countries to be conquered including the destination. For example, if starting and destination countries are neighbors, then your program should return one.
The following connection diagram illustrates the first sample input.
Input
Input to your program will consist of a series of country configuration test sets. Each test set will consist of a board description on lines 1 through 19. The representation avoids listing every national boundary twice by only listing the fact that country I borders country J when I < J. Thus, the Ith line, where I is less than 20, contains an integer X indicating how many “higher-numbered” countries share borders with country I, then X distinct integers J greater than I and not exceeding 20, each describing a boundary between countries I and J. Line 20 of the test set contains a single integer (1 <= N <= 100) indicating the number of country pairs that follow. The next N lines each contain exactly two integers (1 <= A,B <= 20; A!=B) indicating the starting and ending countries for a possible conquest.
There can be multiple test sets in the input file; your program should continue reading and processing until reaching the end of file. There will be at least one path between any two given countries in every country configuration.
Output
For each input set, your program should print the following message “Test Set #T” where T is the number of the test set starting with 1. The next NT lines each will contain the result for the corresponding test in the test set - that is, the minimum number of countries to conquer. The test result line should contain the start country code A the string " to " the destination country code B ; the string ": " and a single integer indicating the minimum number of moves required to traverse from country A to country B in the test set. Following all result lines of each input set, your program should print a single blank line.
Sample Input
1 3
2 3 4
3 4 5 6
1 6
1 7
2 12 13
1 8
2 9 10
1 11
1 11
2 12 17
1 14
2 14 15
2 15 16
1 16
1 19
2 18 19
1 20
1 20
5
1 20
2 9
19 5
18 19
16 20
Sample Output
Test Set #1
1 to 20: 7
2 to 9: 5
19 to 5: 6
18 to 19: 2
16 to 20: 2
Source
问题链接:POJ1603 ZOJ1221 Risk
问题简述:(略)
问题分析:Floyd算法题,不解释。这个题与UVA567是同一个题,只是输出数据略有不同。
程序说明:(略)
参考链接:UVA567 Risk【最短路径+Floyd算法】
题记:(略)
AC的C++语言程序如下:
/* POJ1603 ZOJ1221 Risk */
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
/* Floyd-Warshall算法:计算图中任意2点之间的最短距离
* 复杂度:O(N×N×N)
* 输入:n 全局变量,图结点数
* g 全局变量,邻接矩阵,g[i][j]表示结点i到j间的边距离
* 输出:g 全局变量
*/
const int INF = 0x3f3f3f3f;
const int N = 20;
int g[N + 1][N + 1], n;
void floyd()
for(int k = 1; k <= N; k++)
for(int i = 1; i <= N; i++)
for(int j = 1; j <= N; j++)
g[i][j] = min(g[i][j], g[i][k] + g[k][j]);
int main()
int caseno = 0;
while(~scanf("%d", &n))
memset(g, INF, sizeof(g));
int u = 1, v;
for(int i = 1; i <= n; i++)
scanf("%d", &v);
g[u][v] = g[v][u] = 1;
for(v = 2; v < N; v++)
scanf("%d", &n);
for(int i = 1; i <= n; i++)
scanf("%d", &u);
g[u][v] = g[v][u] = 1;
floyd();
scanf("%d", &n);
printf( "Test Set #%d\\n", ++caseno);
for(int i = 1; i <= n; i++)
scanf( "%d%d", &u, &v);
printf( "%d to %d: %d\\n", u, v, g[u][v]);
printf("\\n");
return 0;
以上是关于POJ1603 ZOJ1221 RiskFloyd算法的主要内容,如果未能解决你的问题,请参考以下文章
ACM/ICPC 之 BFS+状态压缩(POJ1324(ZOJ1361))
ZOJ 1542 POJ 1861 Network 网络 最小生成树,求最长边,Kruskal算法