java使用for循环输出图形 * *** ***** ******* ***** *** *
Posted
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了java使用for循环输出图形 * *** ***** ******* ***** *** *相关的知识,希望对你有一定的参考价值。
输出图形:
*
***
*****
*******
*****
***
*
public class Test5
/**
* @param args
*/
public static void main(String[] args)
// TODO Auto-generated method stub
for (int i = 1; i <= 7; i++)
for (int j = 1; j <= Math.abs(4 - i); j++)
System.out.print(" ");
for (int k = 1; k <= 7-Math.abs(i-4)*2; k++)
System.out.print("*");
System.out.println();
参考技术A public static void main(String[] args)
int xh=1;
for (int i = 0; i < 7; i++)
if(xh<=7)
for(int j=0;j<xh;j++)
System.out.print("*");
System.out.print(" ");
if(i<3)
xh+=2;
else
xh-=2;
追问
改一下吧
追答package design;
public class TestTemp
public static void main(String[] args)
int xh=1;
int kg=3;
for (int i = 0; i < 7; i++)
if(xh<=7)
for(int j=0;j<kg;j++)
System.out.print(" ");
for(int j=0;j<xh;j++)
System.out.print("*");
System.out.println(" ");
if(i<3)
xh+=2;
kg--;
else
xh-=2;
kg++;
楼下那个也可以:用算法弄的
java for循环 输出以下图案并打印出 急!在线等!
Problem Description通过使用双重for循环语句,打印下列图形:
nput
Output
Example Input
Example Output
*
***
*****
*******
*****
***
*
import java.util.Scanner;
public class Main
public static void main(String[] args)
Scanner reader=new Scanner(System.in);
int i,j,k;
for(i=1;i<=4;i++)
for(k=1;k<=4-i;k++)
System.out.printf(" ");
for(j=1;j<=2*i-1;j++)
System.out.printf("*");
System.out.println();
for(i=3;i>=1;i--)
for(k=1;k<=4-i;k++)
System.out.printf(" ");
for(j=1;j<=2*i-1;j++)
System.out.printf("*");
System.out.println();
参考技术A public class Star
public static void main(String[] args)
for(int i=7; i>0; i-=2)
for(int j=0; j<i; j++)
System.out.print("☆");
System.out.println();
for(int i=0; i<2; i++)
System.out.println("☆ ☆");
System.out.println("☆☆☆☆☆☆☆");
main方法换成:
int var = -2;
for(int i=7; i<=7; i+=var)
if(i == 1)
System.out.println("☆");
var = 2;
else
for(int j=0; j<i; j++)
System.out.print(var < 0 ? "▲" : "△");
System.out.println();
倒三角没打出来,自己找去吧。
顺便说一句,如果仅仅只是为了应付作业,那我代表全体IT人鄙视你!
以上是关于java使用for循环输出图形 * *** ***** ******* ***** *** *的主要内容,如果未能解决你的问题,请参考以下文章