And my grandpa is reading a newspaper.

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了And my grandpa is reading a newspaper.相关的知识,希望对你有一定的参考价值。

参考技术A 翻译:并且我的爷爷(或者外公)也正在读报!

POJ2092 LA3157 HDU1347 ZOJ2250 Grandpa is Famous排序

Grandpa is Famous
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 11103 Accepted: 5084

Description

The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in the Guinness Book of World Records as the most successful bridge player ever, whow, that was astonishing!
The International Bridge Association (IBA) has maintained, for several years, a weekly ranking of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player ever because he got the highest number of points.
Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. Since the IBA rankings are now available in the internet he turned to you for help. He needs a program which, when given a list of weekly rankings, finds out which player(s) got the second place according to the number of points.

Input

The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 <= N <= 500) and the number of players in each ranking (2 <= M <= 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly ranking. You can assume that:
in each test case there is exactly one best player and at least one second best player,
each weekly ranking consists of M distinct player identifiers.

The end of input is indicated by N = M = 0.

Output

For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print the identification numbers of all second best players in increasing order. Each identification number produced must be followed by a blank space.

Sample Input

4 5
20 33 25 32 99
32 86 99 25 10
20 99 10 33 86
19 33 74 99 32
3 6
2 34 67 36 79 93
100 38 21 76 91 85
32 23 85 31 88 1
0 0

Sample Output

32 33
1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100

Source

South America 2004

问题链接POJ2092 LA3157 HDU1347 ZOJ2250 Grandpa is Famous
问题简述:(略)
问题分析:排序问题,可以根据计数进行排序,不解释。
程序说明:UVALive中,输出数据每行后带一个空格!
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ2092 LA3157 HDU1347 ZOJ2250 Grandpa is Famous */

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 10000 + 1;
struct Player {
    int num, cnt;
} p[N];

bool cmp(Player a, Player b)
{
    return a.cnt == b.cnt ? a.num < b.num : a.cnt > b.cnt;
}

int main()
{
    int n, m;
    while (~scanf("%d%d", &n, &m) && (n || m)) {
        memset(p, 0, sizeof p);

        for (int i = 1, num; i <= n; i++)
            for (int j = 1; j <= m; j++) {
                scanf("%d", &num);
                p[num].num = num;
                p[num].cnt++;
            }

        sort(p, p + N, cmp);

        int i;
        for (i = 1; p[i].cnt == p[i + 1].cnt; i++)
            printf("%d ", p[i].num);
        printf("%d\\n", p[i].num);
    }

    return 0;
}

以上是关于And my grandpa is reading a newspaper.的主要内容,如果未能解决你的问题,请参考以下文章

TypeError: Cannot read property 'send' of undefined for my commands and a TypeError: Cannot read pro

英语句子 Spring is green with fiowers and songs.

grandpa怎么读 grandpa英文解释

Grandpa是啥意思?

mysql报错:Expression #1 of SELECT list is not in GROUP BY clause and contains nonaggre

Table 'hd_online' is marked as crashed and should be repaired索引损坏