linux下如何将第一行中指定的字符全部替换掉

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了linux下如何将第一行中指定的字符全部替换掉相关的知识,希望对你有一定的参考价值。

使用文本替换

: s/旧的字符/新的字符/g 注意 是在末行模式下

替换当前行中查找到的匹配的所有字符替换掉
参考技术A awk 'if (NR==1) gsub(/指定字符/,"替换后");print $0' command.txt

sed '1s/指定字符/替换后字符/g' command.txt

字符串替换 (replace)

将文本文件中指定的字符串替换成新字符串。 由于目前的OJ系统暂时不能支持用户读入文件,我们编写程序从键盘输入文件中的内容,当输入的一行为end时,表示结束。end后面有两个字符串,要求用第二个字符串替换文本中所有的第一个字符串。

输入格式:

Xi’an Institute of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology. The Institute is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.

end (表示结束)

Institute (第一个字符串,要求用第二个字符串替换)

University (第二个字符串)

输出格式:

Xi’an University of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology.The University is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.

输入样例:

Xi’an Institute of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology.
The Institute is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.
end
Institute
University

输出样例:

Xi’an University of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology.The University is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.
#include<iostream>
#include<cstring>
using namespace std;
int main()

string a,b,c,m;
getline(cin,a);
while(1)

getline(cin,m);
if(m=="end")
	break;
	
a+=‘\n‘;
a+=m;	

a+=‘\n‘;
getline(cin,b);
getline(cin,c);
int found;
found=a.find(b);
while(found!=-1)

a.replace(found,b.size(),c);
found=a.find(b,found+1);	
cout<<a; 
return 0;

  


以上是关于linux下如何将第一行中指定的字符全部替换掉的主要内容,如果未能解决你的问题,请参考以下文章

c语言:如何将字符串中指定的字符替换为另一个指定字符

c语言:如何将字符串中指定的字符替换为另一个指定字符

替换字符串中指定的特殊字符

替换字符串中指定的特殊字符

JAVA 删除字符串中指定的字符

Linux中使用awk输出一段字符中指定的内容