2022第十四届蓝桥杯模拟赛第二期
Posted 上山打老虎D
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了2022第十四届蓝桥杯模拟赛第二期相关的知识,希望对你有一定的参考价值。
第十四届蓝桥杯模拟赛
代码都是自己敲的,不一定对==
1. 最小的2022
问题描述
请找到一个大于 2022 的最小数,这个数转换成二进制之后,最低的 6 个二进制为全为 0 。
请将这个数的十进制形式作为答案提交。
答案提交
这是一道结果填空的题,你只需要算出结果后提交即可。本题的结果为一个整数,在提交答案时只填写这个整数,填写多余的内容将无法得分。
参考答案
2048
低六位都为0,即为
2
6
2^6
26的倍数,手推一下即可
2. 经过天数
问题描述
我们计从 1949 年 10 月 1 日至 1949 年 10 月 2 日为经过了 1 天。
请问从 1949 年 10 月 1 日至 2022 年 1 月 1 日经过了多少天?
答案提交
这是一道结果填空的题,你只需要算出结果后提交即可。本题的结果为一个整数,在提交答案时只填写这个整数,填写多余的内容将无法得分。
参考答案
26390
直接暴力算就行
#include <iostream>
#include <cmath>
#include <string>
#include <stack>
#include <map>
#include <algorithm>
#include <vector>
#include <queue>
#include <deque>
#include <set>
using namespace std;
int leap[12] = 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31;
int main()
int y1 = 1949, m1 = 10, d1 = 1, y2 = 2022, m2 = 1, d2 = 1;
int ans = 0;
ans += leap[m1 - 1] - d1;
for (int i = m1 + 1; i <= 12; i++)
ans += leap[i - 1];
for (int i = y1 + 1; i < y2; i++)
if (i % 4 == 0 && i % 100 != 0 || i % 400 == 0)
ans += 366;
else
ans += 365;
for (int i = 1; i < m2; i++)
ans += leap[i - 1];
ans += d2;
cout << ans << endl;
return 0;
3. 特殊的十六进制数
问题描述
8518 是一个非常特殊的数,如果把这个数看成 16 进制数,它的值为 (8518)16=8161616+51616+116+8=34072,而 34072 正好是 8518 的整数倍。
9558 也是这样一个数,当看成 16 进制时是 38232。
其实长度为 1 的数 0 到 9 都满足看成 16 进制后是自己的整数倍(1倍)。
请问,除开长度为 1 的数,最小的满足这样条件的数是多少?
答案提交
这是一道结果填空的题,你只需要算出结果后提交即可。本题的结果为一个整数,在提交答案时只填写这个整数,填写多余的内容将无法得分。
参考答案
1038
直接暴力算就行
#include <iostream>
#include <cmath>
#include <string>
#include <stack>
#include <map>
#include <algorithm>
#include <vector>
#include <queue>
#include <deque>
#include <set>
using namespace std;
int main()
int i = 10;
while (true)
int temp = i;
int hex = 0;
int cnt = 0;
while (temp)
hex += temp % 10 * pow(16, cnt);
temp /= 10;
cnt++;
if (hex % i == 0)
cout << i << endl;
break;
i++;
return 0;
4. 矩阵的最小路径
问题描述
小蓝有一个 30 行 60 列的数字矩阵,矩阵中的每个数都是 0 到 9 之间的数字。
174094882455171152761423221685761892795431233411387427793198
650286024865090061389344606618496378829135984076361542097372
601657541200146071777733599818266038012509478351201640618984
143988087783837107349651099683484992553337438088068198972282
890781586124258626539246182119762952003918195325258677229419
698255491250839396799769357665825441616335532825361862146291
503649293440596342887581257444442930778730382520372975343211
325351222640703400531067500454956482168314849207060705673849
265774579830223671554026061117300483012903885770893074783710
083450145620356667677191627276513995926532444279237315785832
411595106453089134746365281031552217482363035280722591085079
053410485925413958279617719034175332412908745680774313630190
429314820559328748143552689295945058801322270313370955837837
939182801848609300876356583948397645861551964542532682663945
625356614462682551015176002433628234343684739800880514363921
982340231989891351425389287014819359798014755509282450440511
590838726938103384801541373585690893606978941566666714061214
952341523168827712604946036245881214982452998386986623826275
782780208928205527678781609589000725521486468983551558405472
149903035076783644195574734088152324666290493119955560594634
905391288186024902215444250421277955403412298227858394469856
607272647132163832860126054679347881638761723785858733108109
249157334220127702410373959720286708183036202841837581704881
367895556630088230650972282944827258473951902831431040790814
079538232104075905120989173307660289899942087873076421916033
622143260549608274076012938515668898707915863945382394851328
164677964192631597026176253407553188801750590935427267220117
591817866992665840378311257621611574856498432538327068011953
631534031790352912617015229051836886166704989498756486878095
690013558017746707412183571476823027885971347137127534455141
答案提交
这是一道结果填空的题,你只需要算出结果后提交即可。本题的结果为一个整数,在提交答案时只填写这个整数,填写多余的内容将无法得分。
参考答案
592
很简单的动态规划题,矩阵中每个点保存到当前这个点的最大路径的和,并依次遍历矩阵更新即可。
#include <iostream>
#include <cmath>
#include <string>
#include <stack>
#include <map>
#include <algorithm>
#include <vector>
#include <queue>
#include <deque>
#include <set>
using namespace std;
int main()
int dp[30][60];
freopen("in.txt", "r", stdin);
for (int i = 0; i < 30; i++)
for (int j = 0; j < 60; j++)
char c;
cin >> c;
dp[i][j] = c - '0';
for (int i = 0; i < 30; i++)
for (int j = 0; j < 60; j++)
if (i && j)
dp[i][j] = dp[i][j] + max(dp[i - 1][j], dp[i][j - 1]);
else if (i)
dp[i][j] = dp[i][j] + dp[i - 1][j];
else if (j)
dp[i][j] = dp[i][j] + dp[i][j - 1];
cout << dp[29][59] << endl;
return 0;
5. 质数拆分
问题描述
将 2022 拆分成不同的质数的和,请问最多拆分成几个?
答案提交
这是一道结果填空的题,你只需要算出结果后提交即可。本题的结果为一个整数,在提交答案时只填写这个整数,填写多余的内容将无法得分。
参考答案
33
先生成小于这个数的所有质数,然后使用dfs暴力求解,由于生成的质数的是升序的,因此第一个解即为最多分拆,输出第一个解即可。应该是下面这33个质数。
2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97 101 103 107 109 113 127 139 163
#include <iostream>
#include <cmath>
#include <string>
#include <stack>
#include <map>
#include <algorithm>
#include <vector>
#include <queue>
#include <deque>
#include <set>
using namespace std;
vector<int> primes;
vector<bool> flag;
bool isFind = false;
bool isPrime(int num)
if (num == 1) return false;
for (int i = 2; i <= sqrt(num); i++)
if (num % i == 0) return false;
return true;
void dfs(int sum, int index, int n)
if (sum > n || index >= primes.size() || isFind)
return;
if (sum == n)
vector<int> temp;
for (int i = 0; i < primes.size(); i++)
if (flag[i])
temp.push_back(primes[i]);
cout << temp.size() << endl;
for (int i = 0; i < temp.size(); i++)
cout << temp[i] << " ";
cout << endl;
isFind = true;
return;
if (sum < n)
flag[index] = true;
dfs(sum + primes[index], index + 1, n);
flag[index] = false;
dfs(sum, index + 1, n);
int main()
int n;
cin >> n;
for (int i = 1; i <= n; i++)
if (isPrime(i))
primes.push_back(i);
flag.push_back(false);
dfs(0, 0, n);
return 0;
6. 拷贝时间
问题描述
小蓝正在拷贝一份文件,他现在已经拷贝了 t 秒时间,已经拷贝了 c 字节,文件总共有 s 字节,如果拷贝是匀速进行的,请问小蓝大概还需要拷贝多少秒?
输入格式
输入一行包含三个整数 t, c, s,相邻两个整数之间用一个空格分隔。
输出格式
输出一个整数,表示答案。数据保证答案正好是整数。
样例输入1
3 10 20
样例输出1
30 14 21
样例输入2
30 14 21
样例输出2
15
评测用例规模与约定
对于
50
%
50\\%
50% 的评测用例,
1
<
=
t
,
c
,
s
<
=
1
0
4
1 <= t, c, s <= 10^4
1<=t,c,s<=104。
对于所有评测用例,
1
<
=
t
,
c
,
s
<
=
1
0
9
1 <= t, c, s <= 10^9
1<=t,c,s<=109。
参考答案
#include <iostream>
#include <cmath>
#include <string>
#include <stack>
#include <map>
#include <algorithm>
#include <vector>
#include <queue>
#include <deque>
#include <set>
using namespace std;
typedef long long ll;
int main()
ll t, c, s;
cin >> t >> c >> s;
cout << (s - c) * t / c << endl;
return 0;
7. 单词去重
问题描述
小蓝有 n 个单词,但是单词中有一些是重复的,请帮小蓝去除重复的单词。
输入格式
输入第一行包含一个正整数 n ,表示小蓝的单词数量。
接下来 n 行,每行包含一个由小写字母组成的单词。
输出格式
请输出去除重复后的那些单词。如果一个单词出现了多遍,请保留第一次出现的单词,去除之后出现的单词,按输入的顺序输出。
样例输入
5
lanqiao
hi
hello
hello
lanqiao
样例输出
lanqiao
hi
hello
评测用例规模与约定
对于所有评测用例, 1 < = n < = 100 1 <= n <= 100 1<=n<=100,每个单词的长度不超过 100。
参考答案
直接set去重就行
#include <iostream>
#include <cmath>
#include <string>
#include <stack>
#include <map>
#include <algorithm>
#include <vector>
#include <queue>
#include <deque>
#include <set>
using namespace std;
typedef long long ll;
int main()
int n;
cin >> n;
set<string> s;
for (int i = 0; i < n; i++)
string temp;
cin >> temp;
if (s.find(temp) == s.end())
cout << temp << endl;
s.insert(temp);
return 0;
8. 最短回文串
问题描述
一个字符串如果从左向右读和从右向左读相同,则称为一个回文串,例如 lanqiaoaiqnal 是一个回文串。
小蓝有一个字符串,请将这个字符串右边加上一些字符,使其成为一个回文串。
如果有多种方案,请输出最短的回文串。
输入格式
输入一行包含一个字符串,由小写英文字母组成。
输出格式
输出一行包含答案。
样例输入1
lanqiao
样例输出1
lanqiaoaiqnal
样例输入2
banana
样例输出2
bananab
评测用例规模与约定
对于所有评测用例,1 <= 字符串长度 <= 100。
参考答案
用两个指针一个一个去检测就可以,时间复杂度 O ( n 2 ) O(n^2) O(n2)
#include <iostream>
#include <cmath>
#include <string>
#include <stack>
#include <map>
#include <algorithm>
#include <vector>
#include <queue>
#include <deque>
#include 以上是关于2022第十四届蓝桥杯模拟赛第二期的主要内容,如果未能解决你的问题,请参考以下文章