分数加减乘除法==自己加了乘除法
Posted 隐无影
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了分数加减乘除法==自己加了乘除法相关的知识,希望对你有一定的参考价值。
分数加减法
时间限制: 3000 ms | 内存限制: 65535 KB 难度: 2-
描述
-
编写一个C程序,实现两个分数的加减法
-
输入
-
输入包含多行数据
每行数据是一个字符串,格式是"a/boc/d"。
其中a, b, c, d是一个0-9的整数。o是运算符"+"或者"-"。
数据以EOF结束
输入数据保证合法
输出
-
对于输入数据的每一行输出两个分数的运算结果。
注意结果应符合书写习惯,没有多余的符号、分子、分母,并且化简至最简分数
样例输入
-
1/8+3/8 1/4-1/2 1/3-1/3
样例输出
-
1/2 -1/4 0
-
输入包含多行数据
#define _CRT_SECURE_NO_WARNINGS
#include<stdio.h>
int gcd(int a, int b)//递归求最大公约数
if (b == 0) return a;
return gcd(b, a%b);
int lcm(int a, int b)//最小公倍数
int c = gcd(a, b);//最小公倍数=最大公约数*
return a*b / c;
int main()
int a, b, c, d;
char ch;
while (scanf("%d/%d%c%d/%d", &a, &b, &ch, &c, &d) != EOF)
if (ch == '*')
int temp = a*c;
int temp1 = b*d;
int k = gcd(temp1, temp);
if (temp1 / k == 1)
printf("%d\\n", temp / k);
else
printf("%d\\\\%d\\n", temp / k, temp1 / k);
if (ch == '/')
int temp = a*d;
int temp1 = b*c;
int k = gcd(temp, temp1);
if (temp1 / k == 1)
printf("%d\\n", temp / k);
else
printf("%d\\\\%d\\n", temp / k, temp1 / k);
if (ch == '+' || ch == '-')
int m = lcm(b, d);//求出分母最小公倍数
int n;//n是分子总和
if (ch == '+') n = a*(m / b) + c*(m / d);
else n = a*(m / b) - c*(m / d);
if (n == 0)//如果分子为0,直接输出0
printf("0\\n");
else
int t = gcd(m, n);//求出分子分母最大公约数
n = n / t; m = m / t;
if (m < 0)m = -m, n = -n;//将分母的-号放在分子上
if (m == 1)//如果分母==1,直接输出分子既可
printf("%d\\n", n);
else
printf("%d\\\\%d\\n", n, m);
return 0;
以上是关于分数加减乘除法==自己加了乘除法的主要内容,如果未能解决你的问题,请参考以下文章