编程中的「魔数」(magic number)是什么意思?

Posted Dontla

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了编程中的「魔数」(magic number)是什么意思?相关的知识,希望对你有一定的参考价值。

文章目录


今天学shell编程的时候看到一个“魔数”概念,不知道是什么意思

man magic

MAGIC(5)                                                                                                                                       BSD File Formats Manual                                                                                                                                       MAGIC(5)

NAME
     magic — file command's magic pattern file	//文件命令的魔法模式文件

DESCRIPTION
     This manual page documents the format of the magic file as used by the file(1) command, version 5.11.  The file(1) command identifies the type of a file using, among other tests, a test for whether the file contains certain “magic patterns”.  The file /usr/share/misc/magic specifies what patterns are to
     be tested for, what message or MIME type to print if a particular pattern is found, and additional information to extract from the file.
     //本手册页记录了 file(1) 命令 5.11 版使用的魔法文件的格式。 
     //file(1) 命令使用除其他测试外,对文件是否包含某些“魔术模式”的测试来识别文件的类型。 
     //文件 /usr/share/misc/magic 指定要测试的模式、如果找到特定模式要打印的消息或 MIME 类型,以及从文件中提取的附加信息。

	//额,我都怀疑这个是不是。。。
	
     Each line of the file specifies a test to be performed.  A test compares the data starting at a particular offset in the file with a byte value, a string or a numeric value.  If the test succeeds, a message is printed.  The line consists of the following fields:

     offset   A number specifying the offset, in bytes, into the file of the data which is to be tested.

     type     The type of the data to be tested.  The possible values are:

              byte        A one-byte value.

              short       A two-byte value in this machine's native byte order.

              long        A four-byte value in this machine's native byte order.

              quad        An eight-byte value in this machine's native byte order.

              float       A 32-bit single precision IEEE floating point number in this machine's native byte order.

              double      A 64-bit double precision IEEE floating point number in this machine's native byte order.

              string      A string of bytes.  The string type specification can be optionally followed by /[WwcCtb]*.  The “W” flag compacts whitespace in the target, which must contain at least one whitespace character.  If the magic has n consecutive blanks, the target needs at least n consecutive blanks
                          to match.  The “w” flag treats every blank in the magic as an optional blank.  The “c” flag specifies case insensitive matching: lower case characters in the magic match both lower and upper case characters in the target, whereas upper case characters in the magic only match upper
                          case characters in the target.  The “C” flag specifies case insensitive matching: upper case characters in the magic match both lower and upper case characters in the target, whereas lower case characters in the magic only match upper case characters in the target.  To do a complete
                          case insensitive match, specify both “c” and “C”.  The “t” flag forces the test to be done for text files, while the “b” flag forces the test to be done for binary files.

              pstring     A Pascal-style string where the first byte/short/int is interpreted as the an unsigned length.  The length defaults to byte and can be specified as a modifier.  The following modifiers are supported:
                          B  A byte length (default).
                          H  A 2 byte big endian length.
                          h  A 2 byte big little length.
                          L  A 4 byte big endian length.
                          l  A 4 byte big little length.
                          J  The length includes itself in its count.
                          The string is not NUL terminated.  “J” is used rather than the more valuable “I” because this type of length is a feature of the JPEG format.

              date        A four-byte value interpreted as a UNIX date.

              qdate       A eight-byte value interpreted as a UNIX date.

              ldate       A four-byte value interpreted as a UNIX-style date, but interpreted as local time rather than UTC.

              qldate      An eight-byte value interpreted as a UNIX-style date, but interpreted as local time rather than UTC.

              beid3       A 32-bit ID3 length in big-endian byte order.

              beshort     A two-byte value in big-endian byte order.

              belong      A four-byte value in big-endian byte order.

              bequad      An eight-byte value in big-endian byte order.

              befloat     A 32-bit single precision IEEE floating point number in big-endian byte order.

              bedouble    A 64-bit double precision IEEE floating point number in big-endian byte order.

              bedate      A four-byte value in big-endian byte order, interpreted as a Unix date.

              beqdate     An eight-byte value in big-endian byte order, interpreted as a Unix date.

              beldate     A four-byte value in big-endian byte order, interpreted as a UNIX-style date, but interpreted as local time rather than UTC.

              beqldate    An eight-byte value in big-endian byte order, interpreted as a UNIX-style date, but interpreted as local time rather than UTC.

              bestring16  A two-byte unicode (UCS16) string in big-endian byte order.

              leid3       A 32-bit ID3 length in little-endian byte order.

              leshort     A two-byte value in little-endian byte order.

              lelong      A four-byte value in little-endian byte order.

              lequad      An eight-byte value in little-endian byte order.

              lefloat     A 32-bit single precision IEEE floating point number in little-endian byte order.

              ledouble    A 64-bit double precision IEEE floating point number in little-endian byte order.

              ledate      A four-byte value in little-endian byte order, interpreted as a UNIX date.

              leqdate     An eight-byte value in little-endian byte order, interpreted as a UNIX date.

              leldate     A four-byte value in little-endian byte order, interpreted as a UNIX-style date, but interpreted as local time rather than UTC.

              leqldate    An eight-byte value in little-endian byte order, interpreted as a UNIX-style date, but interpreted as local time rather than UTC.

              lestring16  A two-byte unicode (UCS16) string in little-endian byte order.

              melong      A four-byte value in middle-endian (PDP-11) byte order.

              medate      A four-byte value in middle-endian (PDP-11) byte order, interpreted as a UNIX date.

              meldate     A four-byte value in middle-endian (PDP-11) byte order, interpreted as a UNIX-style date, but interpreted as local time rather than UTC.

              indirect    Starting at the given offset, consult the magic database again.

              regex       A regular expression match in extended POSIX regular expression syntax (like egrep).  Regular expressions can take exponential time to process, and their performance is hard to predict, so their use is discouraged.  When used in production environments, their performance should be
                          carefully checked.  The type specification can be optionally followed by /[c][s].  The “c” flag makes the match case insensitive, while the “s” flag update the offset to the start offset of the match, rather than the end.  The regular expression is tested against line N + 1 onwards,
                          where N is the given offset.  Line endings are assumed to be in the machine's native format.  ^ and $ match the beginning and end of individual lines, respectively, not beginning and end of file.

              search      A literal string search starting at the given offset.  The same modifier flags can be used as for string patterns.  The modifier flags (if any) must be followed by /number the range, that is, the number of positions at which the match will be attempted, starting from the start off‐
                          set.  This is suitable for searching larger binary expressions with variable offsets, using \\ escapes for special characters.  The offset works as for regex.

              default     This is intended to be used with the test x (which is always true) and a message that is to be used if there are no other matches.

              Each top-level magic pattern (see below for an explanation of levels) is classified as text or binary according to the types used.  Types “regex” and “search” are classified as text tests, unless non-printable characters are used in the pattern.  All other tests are classified as binary.  A
              top-level pattern is considered to be a test text when all its patterns are text patterns; otherwise, it is considered to be a binary pattern.  When matching a file, binary patterns are tried first; if no match is found, and the file looks like text, then its encoding is determined and the text
              patterns are tried.

              The numeric types may optionally be followed by & and a numeric value, to specify that the value is to be AND'ed with the numeric value before any comparisons are done.  Prepending a u to the type indicates that ordered comparisons should be unsigned.

     test     The value to be compared with the value from the file.  If the type is numeric, this value is specified in C form; if it is a string, it is specified as a C string with the usual escapes permitted (e.g. \\n for new-line).

              Numeric values may be preceded by a character indicating the operation to be performed.  It may be =, to specify that the value from the file must equal the specified value, <, to specify that the value from the file must be less than the specified value, >, to specify that the value from the
              file must be greater than the specified value, &, to specify that the value from the file must have set all of the bits that are set in the specified value, ^, to specify that the value from the file must have clear any of the bits that are set in the specified value, or ~, the value specified
              after is negated before tested.  x, to specify that any value will match.  If the character is omitted, it is assumed to be =.  Operators &, ^, and ~ don't work with floats and doubles.  The operator ! specifies that the line matches if the test does not succeed.

              Numeric values are specified in C form; e.g.  13 is decimal, 013 is octal, and 0x13 is hexadecimal.

              For string values, the string from the file must match the specified string.  The operators =, < and > (but not &) can be applied to strings.  The length used for matching is that of the string argument in the magic file.  This means that a line can match any non-empty string (usually used to
              then print the string), with >\\0 (because all non-empty strings are greater than the empty string).

              The special test x always evaluates to true.

     message  The message to be printed if the comparison succeeds.  If the string contains a printf(3) format specification, the value from the file (with any specified masking performed) is printed using the message as the format string.  If the string begins with “\\b”, the message printed is the remainder
              of the string with no whitespace added before it: multiple matches are normally separated by a single space.

     An APPLE 4+4 character APPLE creator and type can be specified as:

           !:apple CREATYPE

     A MIME type is given on a separate line, which must be the next non-blank or comment line after the magic line that identifies the file type, and has the following format:

           !:mime  MIMETYPE

     i.e. the literal string “!:mime” followed by the MIME type.

     An optional strength can be supplied on a separate line which refers to the current magic description using the following format:

           !:strength OP VALUE

     The operand OP can be: +, -, *, or / and VALUE is a constant between 0 and 255.  This constant is applied using the specified operand to the currently computed default magic strength.

     Some file formats contain additional information which is to be printed along with the file type or need additional tests to determine the true file type.  These additional tests are introduced by one or more > characters preceding the offset.  The number of > on the line indicates the level of the
     test; a line with no > at the beginning is considered to be at level 0.  Tests are arranged in a tree-like hierarchy: if the test on a line at level n succeeds, all following tests at level n+1 are performed, and the messages printed if the tests succeed, until a line with level n (or less) appears.
     For more complex files, one can use empty messages to get just the "if/then" effect, in the following way:

           0      string   MZ
           >0x18  leshort  <0x40   MS-DOS executable
           >0x18  leshort  >0x3f   extended PC executable (e.g., MS Windows)

     Offsets do not need to be constant, but can also be read from the file being examined.  If the first character following the last > is a ( then the string after the parenthesis is interpreted as an indirect offset.  That means that the number after the parenthesis is used as an offset in the file.  The
     value at that offset is read, and is used again as an offset in the file.  Indirect offsets are of the form: (( x [.[bislBISL]][+-][ y ]).  The value of x is used as an offset in the file.  A byte, id3 length, short or long is read at that offset depending on the [bislBISLm] type specifier.  The capi‐
     talized types interpret the number as a big endian value, whereas the small letter versions interpret the number as a little endian value; the m type interprets the number as a middle endian (PDP-11) value.  To that number the value of y is added and the result is used as an offset in the file.  The
     default type if one is not specified is long.

     That way variable length structures can be examined:

           # MS Windows executables are also valid MS-DOS executables
           0           string  MZ
           >0x18       leshort <0x40   MZ executable (MS-DOS)
           # skip the whole block below if it is not an extended executable
           >0x18       leshort >0x3f
           >>(0x3c.l)  string  PE\\0\\0  PE executable (MS-Windows)
           >>(0x3c.l)  string  LX\\0\\0  LX executable (OS/2)

     This strategy of examining has a drawback: You must make sure that you eventually print something, or users may get empty output (like, when there is neither PE\\0\\0 nor LE\\0\\0 in the above example)

     If this indirect offset cannot be used directly, simple calculations are possible: appending [+-*/%&|^]number inside parentheses allows one to modify the value read from the file before it is used as an offset:

           # MS Windows executables are also valid MS-DOS executables
           0           string  MZ
           # sometimes, the value at 0x18 is less that 0x40 but there's still an
           # extended executable, simply appended to the file
           >0x18       leshort <0x40
           >>(4.s*512) leshort 0x014c  COFF executable (MS-DOS, DJGPP)
           >>(4.s*512) leshort !0x014c MZ executable (MS-DOS)

     Sometimes you do not know the exact offset as this depends on the length or position (when indirection was used before) of preceding fields.  You can specify an offset relative to the end of the last up-level field using&’ as a prefix to the offset:

           0           string  MZ
           >0x18       leshort >0x3f
           >>(0x3c.l)  string  PE\\0\\0    PE executable (MS-Windows)
           # immediately following the PE signature is the CPU type
           >>>&0       leshort 0x14c     for Intel 80386
           >>>&0       leshort 0x184     for DEC Alpha

     Indirect and relative offsets can be combined:

           0             string  MZ
           >0x18         leshort <0x40
           >>(4.s*512)   leshort !0x014c MZ executable (MS-DOS)
           # if it's not COFF, go back 512 bytes and add the offset taken
           # from byte 2/3, which is yet another way of finding the start
           # of the extended executable
           >>>&(2.s-514) string  LE      LE executable (MS Windows VxD driver)

     Or the other way around:

           0                 string  MZ
           >0x18             leshort >0x3f
           >>(0x3c.l)        string  LE\\0\\0  LE executable (MS-Windows)
           # at offset 0x80 (-4, since relative offsets start at the end
           # of the up-level match) inside the LE header, we find the absolute
           # offset to the code area, where we look for a specific signature
           >>>(&0x7c.l+0x26) string  UPX     \\b, UPX compressed

     Or even both!

           0                string  MZ
           >0x18            leshort >0x3f
           >>(0x3c.l)       string  LE\\0\\0 LE executable (MS-Windows)
           # at offset 0x58 inside the LE header, we find the relative offset
           # to a data area where we look for a specific signature
           >>>&(&0x54.l-3)  string  UNACE  \\b, ACE self-extracting archive

     Finally, if you have to deal with offset/length pairs in your file, even the second value in a parenthesized expression can be taken from the file itself, using another set of parentheses.  Note that this additional indirect offset is always relative to the start of the main indirect offset.

           0                 string       MZ
           >0x18             leshort      >0x3f
           >>(0x3c.l)        string       PE\\0\\0 PE executable (MS-Windows)
           # search for the PE section called ".idata"...
           >>>&0xf4          search/0x140 .idata
           # ...and go to the end of it, calculated from start+length;
           # these are located 14 and 10 bytes after the section name
           >>>>(&0xe.l+(-4)) string       PK\\3\\4 \\b, ZIP self-extracting archive

SEE ALSO
     file(1) - the command that reads this file.

BUGS
     The formats long, belong, lelong, melong, short, beshort, leshort, date, bedate, medate, ledate, beldate, leldate, and meldate are system-dependent; perhaps they should be specified as a number of bytes (2B, 4B, etc), since the files being recognized typically come from a system on which the lengths are
     invariant.

BSD                                                                                                                                                 April 20, 2011                                                                                                                                                BSD
 Manual page magic(5) line 158/240 (END) (press h for help or q to quit)

编程中的「魔数」(magic number)是什么意思?

“魔数”有贬义词、中性词、褒义词三种用法,默认为贬义词。

1、贬义词“魔数”

指的是代码中出现的没有说明的数字。

代码中突然出现一个没说明用途的数字会让其它阅读代码、维护代码的的人非常难受。

例如:

const int N = 2073600;
for (int i=0; i<N; i++)
  ......

看代码的人需要猜2073600是什么意思,而且特别难猜。改成这样就清楚多了:

const int WIDTH = 1920;
const int HEIGHT = 1080;
int totalPixels = WIDTH * HEIGHT;

这里的“魔数”就是指代码中直接出现的数字。

现代编程规范比较忌讳这样写代码,一方面看不懂意思,另一方面如果2073600这个数字多次出现,一旦需要修改的时候就需要全部找出来改掉,一旦少改一处就会产生BUG,非常麻烦。

我们在编程中要尽可能避免使用“魔数”,例如写3.1416这种数字,也应该改为数学库中的π常数,例如Unity中的Mathf.PI

2、褒义词“魔数”

最典型的例子就是现代3D游戏之父约翰·卡马克在雷神之锤中的那个魔数:

i = 0x5f3759df - ( i >> 1 );

配合前后的代码,这句代码可以快速计算一个数字的平方根的倒数。具体推导过程比较复杂,涉及到浮点数的原理。

这个靓丽的骚操作给了其它人非常大的震撼,是那个年代的大神级编程技术的缩影,所以被人们怀着敬仰之情称之为“魔数”,全称为“如魔法一样神奇的数字”。

3、中性词“魔数”

某些具有特定格式的文件,喜欢在文件开头写几个特殊的字符以表明自己的身份,以便验明正身。

例如常见的几种图片格式的文件:

  • JPEG (jpg),文件头:FFD8FF
  • PNG (png),文件头:89504E47
  • GIF (gif),文件头:47494638
  • Windows Bitmap (bmp),文件头:424D

如果你用16进制编辑器打开一个文件,它的开头不是FFD8FF,那就不是jpg文件。这个魔数一般会在相关文件标准中进行规定,所有人都要遵守。

其它答主也列举了多种“魔数”,我再补充一个常用的魔数——Unicode的BOM魔数。

由于它在Windows记事本中也会出现,所以我们会经常接触到它,虽然没有感觉。

打开一个记事本,随便输入一些内容,然后另存为。另存的时候可以选择编码

  • 如果保存为Unicode,文件开头就会出现FF FE。
  • 如果保存为Unicode big endian,文件开头就会出现FE FF。
  • 如果保存为UTF-8,文件开头会出现EB BB BF。

这些数字不仅能代表它是什么编码,还能指定读取编码的顺序。

细节就不谈了。说这个例子是因为Windows记事本曾经出现过一个非常神奇的bug——你无法以ANSI编码保存一个内容为“联通”的文本文件。

这个问题是因为ANSI编码保存时,开头没有“魔数”,导致记事本识别不出文件是什么编码。

而且“联通”两个字的GBK编码容易被错误识别为UTF-8编码,所以出了问题。

这个小BUG曾被作为微软和电信私通打击联通的证据 。

以上是关于编程中的「魔数」(magic number)是什么意思?的主要内容,如果未能解决你的问题,请参考以下文章

幻数(magic number)

vue 里怎么通过魔数(magic number)去限制上传文件类型?

vue 里怎么通过魔数(magic number)去限制上传文件类型?

linux中的magic number是啥意思

Jvm(34),class文件结构----魔数,版本号

聊聊编程中的 “魔数”