Bailian3726 仙岛求药BFS
Posted 海岛Blog
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Bailian3726 仙岛求药BFS相关的知识,希望对你有一定的参考价值。
总时间限制: 1000ms 内存限制: 65536kB
描述
少年李逍遥的婶婶病了,王小虎介绍他去一趟仙灵岛,向仙女姐姐要仙丹救婶婶。叛逆但孝顺的李逍遥闯进了仙灵岛,克服了千险万难来到岛的中心,发现仙药摆在了迷阵的深处。迷阵由M×N个方格组成,有的方格内有可以瞬秒李逍遥的怪物,而有的方格内则是安全。现在李逍遥想尽快找到仙药,显然他应避开有怪物的方格,并经过最少的方格,而且那里会有神秘人物等待着他。现在要求你来帮助他实现这个目标。
下图 显示了一个迷阵的样例及李逍遥找到仙药的路线.
输入
输入有多组测试数据. 每组测试数据以两个非零整数 M 和 N 开始,两者均不大于20。M 表示迷阵行数, N 表示迷阵列数。接下来有 M 行, 每行包含N个字符,不同字符分别代表不同含义:
- ‘@’:少年李逍遥所在的位置;
- ‘.’:可以安全通行的方格;
- ‘#’:有怪物的方格;
- ‘*’:仙药所在位置。
当在一行中读入的是两个零时,表示输入结束。
输出
对于每组测试数据,分别输出一行,该行包含李逍遥找到仙药需要穿过的最少的方格数目(计数包括初始位置的方块)。如果他不可能找到仙药, 则输出 -1。
样例输入
8 8
.@##…#
#…#.#
#.#.##…
…#.###.
#.#…#.
…###.#.
…#.…
.#…###
6 5
..#.
.#…
…##.
…
.#…
…@
9 6
.#…#.
.#.*.#
.####.
…#…
…#…
…#…
…#…
#.@.##
.#…#.
0 0
样例输出
10
8
-1
问题链接:Bailian3726 仙岛求药
问题简述:(略)
问题分析:最短线路问题,用BFS来解决。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C++语言程序如下:
/* Bailian3726 仙岛求药 */
#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
using namespace std;
const int dr[] = -1, 1, 0, 0;
const int dc[] = 0, 0, 1, -1;
const int NM = 20;
int m, n, sr, sc, er, ec;
char b[NM][NM + 1], vis[NM][NM];
struct Node
int row, col;
;
int bfs(int row, int col)
queue<Node> q;
memset(vis, -1, sizeof vis);
vis[row][col] = 0;
q.push(row, col);
while (!q.empty())
Node t = q.front();
q.pop();
for (int i = 0; i < 4; i++)
int nextr = t.row + dr[i];
int nextc = t.col + dc[i];
if (nextr < 0 || nextr >= m || nextc < 0 || nextc >= n || b[nextr][nextc] == '#' || vis[nextr][nextc] >= 0)
continue;
vis[nextr][nextc] = vis[t.row][t.col] + 1;
if (nextr == er && nextc == ec)
return vis[nextr][nextc];
q.push(nextr, nextc);
return -1;
int main()
while (~scanf("%d%d", &m, &n) && (m || n))
for (int i = 0; i < m; i++)
scanf("%s", b[i]);
for (int j = 0; j < n; j++)
if (b[i][j] == '@')
sr = i, sc = j;
else if (b[i][j] == '*')
er = i, ec = j;
printf("%d\\n", bfs(sr, sc));
return 0;
以上是关于Bailian3726 仙岛求药BFS的主要内容,如果未能解决你的问题,请参考以下文章